Problems with SkechUp free when exporting model to slicer

I want to use SketchUp free for creating models for my 3D-printer a FlashForge Adventurer 3. I have made a simple box model 3x3x1.5 cm and using the Flashforge Flashprint version 5 slicer.
When I open the stl file, Flashprint says the model have errors, but doesn’t tell what errors. After I choose to do a repair of the model, and view the model, it looks ok, but the size has decreased to 3x3x1,5 mm!
Any tips where the problem is?
I newbie on this, and I have no clue.

hmmm when exporting / importing files, you can sometimes precise the unit.

say, I export a dxf from sketchup and import it in illustrator :
as I export, sketchup will ask me what “units” are. I can tell it “well an unit is a cm”. therefore , the file is coded suchas 1unit = 1cm
When I import in illustrator, he asks me again “what are the units”. if I say “well it’s mm” then it will import as 1unit = 1mm
making my file 10 times too small.

Here it seems to be a similar case, SU exports a STL in the unit it was made, but your slicer imports it as mm. no big deal, there are solutions.

Since you’re in the free version, you have no such question when exporting. I just did a test, it exports size 1, si your stl cube should be 3x3x1,5cm

(you can share the stl here if you want us to check, just drag the file in the answer window)

So I guess your Slicer reads STL as mm files. 3 cm became 3 units, and 3 units became 3mm

I see 3 solutions, from the top of my head :

  • switch your file in mm in sketchup before exporting. you should then have a stl 30mm wide

  • check your slicer for import option

  • import in your slicer, and scale it up 10 times.

I don’t know your slicer (any slicer really), don’t know if solution 2 is possible, they might not allow you to change the import preferences. But solution 3 should be feasible adjusting scale of the print should be a normal action for any slicer.

Thanks for your answer!

It looks there is some mismatch on units and lengths, between sketchup and the slicer. I tried to change my model lengths to mm, and then the slicer got the same lengths.

As I will only print small models, then using mm for lengths is ok.

Generally slicers only work in millimeters or inches. The .stl file format is unitless so when you import the file into the slicer it will read it as millimeters instead of centimeters. You can leverage that when you model things. I normally model for 3D printing with units set to meters. For example, I modeled this clip with the dimensions as shown.

And here are a pair of them after printing. They are 35.8 millimeters tall.

1 Like

Strange, but good to know. Thanks!

I use FlashPrint, when drawn in inches, I export as mm. The size is correct.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.