Scale Error for Exported STL File for 3D Printing

stl
#1

I am trying to 3D print an object designed in Sketchup, exported as an .stl file. When I view the .stl file the units have changes (some scaling factor) or there are none, and my model is now extremely small. The problem doesn’t appear to be an issue with my model itself. Ideas on how to fix this scaling issue? Model is attached and would attach the .stl files but not allowed to as a new user… Here are several things I’ve considered:

  1. The model is a solid. I’ve confirmed this as it has a volume, I can use the solid tools on it, and I’ve run the solid checker extension on it, which gives no errors.

  2. The model is a component before I export it as a .stl file.

  3. All faces are in the proper direction as far as I can tell. Again, no errors using the solid checker.

  4. The scaling factor looks to be something like 25.263158… This doesn’t appear correct or the right way to do things. This model in inches, precision was in decimals and out 4 places. If I switch back to architectural, it’s at 1/64" (i.e. either way, small). This is where I think the issue might be based on other forum posts but no luck thus far figuring it out.

  5. Exporting the file I am given several options (i.e. inches or mm, ASCII or binary) but don’t know what to choose. Model is in inches so I’ve gone with that but with no success. The exported .stl files appear too small (~250Kb). There is a difference in file size when exporting .stl files using v.17 vs. Pro (my Wife has the pro license), with the “Pro” .stl file around (1Mb) but neither is scaled appropriately or printable.

SnowProbe_skp2017_20190122.skp (1.9 MB)

0 Likes

#2

STL files are unit-less so it doesn’t matter what units you used in SketchUp. You need to tell your slicer what units you want it to use.

You don’t need the 3D build volume component. I would remove that from the file.

Yes. The faces seem to have the correct orientation.

Is the tall cylinder supposed to be 4.25 in. tall? If that’s the size you want for the print, you need to tell the slicer that you’reusing inches. No need to do anything in the export options.

1 Like

#3

@DaveR thanks for the help. The slicer software was the key. I don’t have a 3D printer myself, I was sending the files off to the library so couldn’t see exactly what was going on. I downloaded Makerbot Print and imported the .stl file – it was ALL THE DIFFERENT MODEL COMPONENTS, not just the one individual component I thought I was exporting.

How I got it to work: I copied and pasted each individual component into it’s own .skp file and exported its own .stl file. When these files were imported into Makerbot Print, each was alone and the correct size. Slower but I was able to import each one at a time.

Cheers,
Hubedavi

0 Likes