STL Export Problem(s) - SOLVED


#1

Have an extremely simple model that I’ve created that I’d like to export as an STL for 3D printing. But when I import the STL file into my slicer software (Slic3r 1.31.6-prusa3d) there are visible errors in the model. Before I purchased a 3D printer, I invested a little time in learning SketchUp but am having all sorts of problems with the STL export plugin. I’d like to continue to use SketchUp, but designing things is challenging enough… : ) I’ve attached the .skp file as well as a couple screen captures. Thanks in advance for any solutions anyone can offer!

WaterStop.skp (93.6 KB)


#2

You have to convert to component, click on entity info, if it reports solid then export but is not so you need to fix.
Change you dimensions to in" other wires it reports 0 vol after you fix.
Use the solid inspector to fix problems , I exploded then made it a component to remove a nested instance and it reports solid after repairs. Then export to your slicer.
I have the repaired model nut think you should learn it. Let me known if you want it??


#3

Thanks for your response! Happy to learn. Thank-you for the tip on converting to component. When I select the component and go to Window --> Entity Info, and I can’t see anything about whether it’s “solid” or not. Have changed to inches too and still not seeing anything about volume. Can you elaborate? Thanks!


#4

The box at bottom of that entitiy will report vol if it is, if not it will not.
Suggest you install the solid Inspector form thr extension warehouse it will report problem areas.


#5

The part has two internal faces where the frame and the curvy part meet. Erase them and the edge at the corner that connects them and the part becomes a “solid”. Two of the faces in the frame are reversed, you should also fix their orientation.

Anssi


#6

Just as follow up – thank-you everyone for the help and suggestions! There were two main things I did to solve my issue.

First, I removed a line from the interior of my model, which got rid of two internal planes that were probably causing part of my problem. To do that, I either chose the View -> Face Style -> X-ray option, or hid specific panes of the model to see the inside. On the inside, I looked for lines and planes that didn’t make sense, the goal being to make the entire object contiguous on the inside.

Second, once I was finished with the repairs that looked necessary, I used CMD-A to select all the pieces of the model and chose Edit -> Make Component.

Another person suggested to make sure that all of the exterior planes were facing to the exterior of the model. I’m still learning a bit about this, but it was suggested to me that this could make a difference as well.

An honorable mention is Thomas Thomassen’s CleanUp3 plugin. I want to learn to fix things myself, but this may be a helpful automated took to solve some of your problem.

Anyhow, I hope someone else can find these suggestions helpful, thanks again to everyone who reached out!