Problems with stl models

I am having difficulties with stl models in terms of importing and exporting.

I have tried to import but there is no ‘menu’ item for import. I used insert but I am not sure that is what I want. I want to import the whole model as a model.

What do I do about the scale/template of the imported model and the exported model. I have inserted a stl model and answered the question with millimetres and meters. Meters gives me a visible model in Sketchup but I have no idea about how to export. I did export one but when I tried to slice it locked up my computer. I created a simple model and exported it but it also would not slice.

When I insert a model how do I get it to import to a spot in Sketchup that when I export it it is at a spot that can be sliced and printed. I know that is a ■■■■ description but I cannot do any better yet.

Thanks,
Morris

I assume you want to import the STL into Sketchup so you can modify it before 3D printing it, otherwise you would send the original STL direct to your slicer. You should be able to do this, first let’s have a look at the file you are working with. Can you post the STL here on the forum? Just drag the file off your desktop and drop it into a response window. There are some tricks and best practices to working in SketchUp for 3D printing. A useful trick is to work in meters and think of them as mm. So you are really working at 1000x scale which avoids many of the tiny face issues that can occur otherwise. Since the STL format is unitless you can set your slicer to import in mm and you will not ever have to scale the object. Some STL files can be very tessellated when imported to SketchUp and difficult to work with, it depends on how they were made. So let’s start with a look at your beginning file.

Insert is the right way to place it. You can resize the imported object to an exact size, but, you might want to work on the object at a large size, to make the smaller geometry work better.

To download an STL you would click the three lines menu, choose Export, STL.

I would use Cura or Meshmixer to get the STL to be the right size for printing. Those tools can do a lot of things you need for printing that SketchUp doesn’t do easily.

Hi there,
Thanks for responding.

I have attached the stl here. It is a small simple model and I was using it to test while trying to get ‘something’ to work. My philosophy : use the simplest thing to get the path working. Also, I certainly would send the original file to slice and print.

I am trying to get working : import stl - export it directly back out, import stl - modify and export back out - test with slice/print, create a model in sketchup - export it as stl then test. If I get those working I should be fixed.

Also, I need to get the mm/meters stuff working.

Thanks,
Morris

DialOrig.stl (90.6 KB)

I’m not sure why you wouldn’t want to use Insert since that’s the way to add the .stl file to your SketchUp file. It works fine for me.

Due to the inherent nature of the .stl file, it will come in with a lot of excess geometry. Many of the edges will be coplanar meaning you can erase them. The rest can be softened to give a smooth appearance. Once you’ve cleaned it up, you can go ahead and make whatever modifications you want.

FWIW, in the case of the file you shared, it might actually be faster to model it from scratch than to clean up the .stl. This isn’t unusual, though.

To continue with my effort to figure out this web version of Sketchup I have another question(s).

I have created a very simple model in Sketchup (extruded rectangle) and exported it as stl. I then used slic3r to slice it and octoprint to print it. All of that happened. The thing that printed was extremely tiny (maybe 1mm). I now that I need to deal with dimensions so I set about trying to ascertain what the dimensions are for the model in Sketchup, are they in mm, cm, m, in, ft or what. I looked for a way to find that in Sketchup and in Googling and once more I ran headlong into the gap between what I have (Sketchup shop) and what is documented. Everything that I could find shows the pro or prior versions of screens and descriptions which I can deal with but so far helps me very little with this web version.

Alert: I will probably use wrong terminology.

Can someone tell me how to see what the dimensions are for the model, like 2mm x 3mm x 4mm or 2cm x 3cm x 4cm or meters or inches, or feet? Also, how to go about changing, from cm to m for example?

Thanks in advance.
Morris

What units were you using when you created the model? And what units did you choose when you imported the model into you slicer? By design, .stl files have no units. If you were modeling in inches but import into the slicer in mm, your model will print roughly 25% the size you modeled it.

Quick example:

A block 20mm by 20mm by 40 mm

After exporting .stl, I uploaded it to i.materialise. I select millimeters for the units before uploading.

I did not specify units to create the model because there is nowhere in the process of creation where that is necessary. Where are units specified in the model, the units of the model should be available somewhere.

Of course there is. When you start a SketchUp model you select a template and choose the units in the process.
Screenshot - 12_7_2020 , 3_07_29 PM

Or you can change the units after starting it using the settings in Model Info.

When you make the model you should be entering dimensions as you go so the model is created at the correct size.

If you are just eyeballing and creating a randomly-sized model, that’s what you’ll get out of it.

Hi Dave,
I really appreciate your help. I have now created a model in Sketchup and exported it as stl and it is now printing. I found that Slic3r was operating in mm so using the info from you I figured out what units the Sketchup model was, changed it to mm and then resized the model to be a printable size.

Like I said I really appreciate the help.

Morris

1 Like

Good deal. For future models you can just start with mm and model accordingly. Saves you a bunch of work.