Export STL with dimensions


#1

I created a model to scale but it seems as if the dimensions are either lost or scaled when I export as STL. I would like to send this to a 3D printer and not have to scale it with the 3D printer software.

I tried both “save as>STL” and “Export STL” with the same results. The maximum dimension should be 12.5" on the model I attached here.

grassrake.skp (105.7 KB)


#2

The stl file format has no ability to convey units. The user has to manually set the scale in the importing app to match that of the source.


#3

This is correct; .stl is a ‘unitless’ file format. Just be sure that your export units (set on the .stl export options in SketchUp) match the import units on whatever application you’re using to control your printer. Not all slicer applications allow you to configure units for import and all of them assume something. I think Cura assumes models are imported in mm, if that’s what you’re using.

It is easy to tell what your slicer is assuming, if you think it through. Any difference in metric units will be off in scale by a decimal place or two. If you have to scale by anything else, then your slicer is caught between metric and imperial units.