STL file printing at a Microscopic size

I created a small file in Sketchup Diameter is 2 inches and the height is 1 1/4 inches. The top is flat. I export it as an STL and when I import it I need to look for it on the screen it is so small. Then I enlarge it, slice it, and print it and it prints so small if it wasn’t in the middle of my plate it would be difficult to find.

Any suggestions??

You need to figure out what the units of measurement are, and then scale it up accordingly in the slicer.
What slicer are you using, also what are the units of measurement in the model?

Creality

The diameter is 2 inches and the height is 1 1/4 inches.

What software do you use for slicing? Aside from the units issue, I would model it much bigger in SketchUp, then let your other application do the scaling.

To what do you have the export units set in SketchUp?

I thinkn I’ve shown you this before but when I model for 3D printing I model with SketchUp’s units set to Meters. I also have the export units set to either Model Units or Meters. Here’s an example.
Footplate Skid for 3D Print

3D Printed Wheelchair Footplate Skids

These are designed to snap onto a 3/4 in. dia. tube.

The slicer I have only uses millimeters for import units. If I wanted to model your object so it prints out at 2 inches in diameter and all of my known dimensions are in inches I would start by modeled as if 2 inches was 2 meters. Then I would scale the model up by a factor of 25.4 so 50.8 mm equals 50.8 meters. Then export to .stl with export units at Meters and import into the slicer in millimeters. Everything would be the right size.

By the way, if you were exporting your 2 in. dia. model with Inches as the export units but your slicer is reading the fille in millimeters, the object would only be 2 mm across.

FYI you have certainly assisted me in the past but not with 3-D stuff. I am very grateful for your assistance.

Thanks I did discover that the slicer was importing my 2 inches as 2 mm.
I did scale it up to 50mm and 31.75mm. It printed in what appeared to be the correct size. However the print quality was a real mess, (unlike the other stuff I have printed from other software). I suspect that this has to do with how I am exporting it. Can you tell me where it is that I would select the output units. When I export I just get a choice of STL and then the name of the file.
Also is there something I need to do when I create the file like make it solid or something like that. If so can you give me some ideas as to how to accomplish that?

There’s an Options button. Click on that.

A mess how? Part of the reason I model in meters is because I can use more sides for arcs and circles and get smoother curved surfaces.

SketchUp will identify objects (groups and components) as solids if every edge in the object is shared by exactly two faces. That means no stray edges, no holes in surfaces, and no internal faces. Also you need to ensure that all faces are oriented correctly. No exposed back faces. The print media goes on the back side of faces while there will be air on the front side. Make your objects components or groups before you export to .stl and check Entity Info to see that they are reported as solid.

You can use extensions like Solid Inspector 2 to help identify problems and in some cases fix them.

Here’s the meshes for another model. You can see there are large numbers of sides in the curves. The shafts are 1 inch diameter. 25.4 meters in the SketchUp model.
U-Joint for 3d print mesh

The resulting parts:
U-Joint 3D Printed

And assembled:
Ujoint

1 Like

Printing Mess
This is what I mean by a mess.

Ah … Printer mess not model mess. I’ve had that happen. It’s annoying.