STL Export - tiny object

I have produced a drawing in SketchUp which is approx 2" by 1" by 1/2". When I use ‘Export STL’ the file is produced but when I try to download into ‘Create and Print’ for my 3D printer, it appears as a minute dot on the grid. I have of course rechecked my measurements with the measurements tool and they are correct.
I have tried with a previously created .STL file and that is ok, but any new .STL file I try to create, comes out so tiny it is almost invisible with a print time of around 20 seconds, and I know from past experience it should take around 45mins for this object.
Any ideas as to why the object doesn’t come out the correct size please?

Check the settings in the export options.

Yes setting correct, no problem there, set to inches and ASCII which is normal for my printer setup.

What about import units on the other end?

Import setting all correct, as I said a previously created STL file works fine, however I tried the same drawing and created another .STL file for it and it too come out very small this time.

Could you attach the .skp so I can test it on my system.

Remote stabiliser.skp (1.2 MB)

Not done this before hope this works ok.

Box’s file works.

Still the same absolutely minute.
Interestingly the file shows as 11KB but other files of similar size objects show as 200KB or similar.
Just noticed the file I sent you shows as 1.2MB but the skp one you returned shows 47.9KB. no idea if this is significant.
I am afraid I am going to have to give up on this at the moment as have a lunch engagement and the pressure is on to get ready!!!

I purged the worthless 3D Printer component and it’s materials which accounts for the file size difference.

Try this one
Remote stabiliserBox.stl (60.5 KB)

Yes! Brilliant! looks good to me, not sure I understand what you did?

I scaled it up by 25.4.
I don’t work in inches so I scaled it by the equivalent ration of an inch to a millimeter.

1 Like

I don’t normally work in inches either, but it was easier in this case, think I will stick to mm in future.
Will print it later and see how it works out.
I thank you very much for all you help.

I really cannot say what is happening here. When I take the model as originally posted, export it to STL and import the result back into SketchUp with inches as the unit, the result is the same size. Is your 3D printer software expecting the file to be in Millimeters?

Will have to check up on that, but sorry don’t have time now, as transport is waiting,
So many thanks again and have a good day.

When I export from SketchUp as .stl inches then import back into SketchUp as inches, it comes in 12 times too big as if its importing it as feet. To get it come back as the same size I have to export as inches and import as feet.

Importing the same .stl into Blender and Cheetah3D, the stl comes in at the expected size. They are kind of unitless but the height was 0.4 inches and it comes in as 0.4.

@Box’s file comes in 25.4 times bigger in other software, but comes in 305 times (25.4 x 12) bigger in SketchUp when importing as inches.

Sorry had to leave so abruptly yesterday. I have since re-drawn the item in SU using millimetres and it all works perfectly. Interestingly this was the first time I have drawn anything using inches, and there is nothing in the information on the printer that says it only accepts mm. Anyway problem solved for now, prototype printed ok but need a little refinement on the measurements. Just in case you are interested, it is to clip onto the back of the TV remote control to make it more stable. I used inches because when measuring with calipers it came out in exact measurements instead of fractions of a mm. Won’t do that again!!
So many thanks for your help.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.