Scaling problem


#1

I scaled my model up 100 million times so that I could fix all of the tiny imperfections of my model. My model consisted of several groups when I scaled up. I noticed that in the 100 million times version sketchup doesn’t recognize any of my model that I had (the groups previously mentioned). Meaning if I try to click on my group it will not work and rather it will select whatever is behind it. It is as if my model has become invisible to sketchup even though I can see it just fine. The second issue is that I don’t know how to scale it back down to its original size. I tried it and since I was so zoomed out due to the 100 million times scale the origin looks like a tiny speck and I can’t zoom in that far. I am basically just stuck as a giant but I need it to be back down to normal size.

Any feedback would be greatly appreciated

Thanks,
Matthew Littman


#2

100 million times. Really?


#3

lol I figured the bigger it was the easier it would be for me to zoom in and fix things


#4

This probably cannot be classified as a technical problem…more like a user induced issue. To state the obvious, Matthew, try using a reasonable scale for this purpose…maybe somewhere between 10x and 100x should do. Plus this makes the math pretty simple for scaling the model back down to its original size.

You can use the most recent backup (.skb) file to recover the original model and work from there. You will need to change the file type to .skp though.


#5

I have already completed the model and I have spent a month doing so, I can’t go back now


#6

You got rattled and saved your “bad” model means your skb file is bad also if you even have back up option set.
Several approaches: Try and see if you can select the groups in the outliner, and then reset scale ( You will have to do one at a time I think); draw a long line say 1000 meters long and the scale it down by 1/10^3. You can repeat and sacle down to size you want; post you model here and let someone fix for you


#7

Open the model and hit Zoom extents, then Ctrl+a to select everything, then hit s to scale, grab a corner and scale down by 0.001.
Hit zoom extents again and check the size of something. If it is still massive rinse and repeat until you are able to control the geometry.
I think you will find that it doesn’t take much scaling down to get it working again.


#8

Open the model.
Zoom extents.
If you have a part that is a known dimension - say it should be 10m long ?
Use the tapemeasure tool an pick the two points that define it.
Type 10m +
When prompted agree to scale the model.
Zoom extents again.
Everything should now be about the right size.
Repeat the tapemeasue-scaling to get it exactly right.
The advantage of this method is that all groups/components get scaled, and even locked, and hidden things or those on OFF layers should get processed too.
When you are using Scale you need to ensure everything is selected, otherwise objects that are not currently available for selection…


#9

Thank you, however now when I try to zoom in it just zooms all the way out so that my model is a speck, it is very touchy, how can I fix that


#10

I actually also just tried importing it into a new model and hundreds of faces are missing why is that?


#11

Isn’t it about time to exclude what the model is? To give us a clue. What makes it “necessary” to scale it up 100 million times? There are many things involved that could go wrong.
Like in your last post:

Does this mean that there are openings in the wireframe where there should be faces?
Or have many groups of vertices merged into a few due to the distances between them being to small for SketchUp to handle? Two entirely different results!
Tell us more about the original model and why scaling up so much was that important. For sure it is a workflow to introduce a variety problems.


#12

Also, how come you only noticed these problems after a month?


#13

I had noticed them earlier than that, but I figured I would be able to fix them once i finished modeling. How do I post the model so you can look at it for yourself? it says I cant upload because the file is too big


#14

also keep in mind it took me a month because a) I was being a perfectionist, b) I didn’t start using soap and bubble until near the end, and c) I am still relatively new to sketchup, only started in the fall. I was trying to use soap and bubble earlier and this is why i scaled it up so much. For soap and bubble you need a complete loop without gaps. For some reason when I tried to use it it kept saying that it wasn’t a closed loop even though it looked like it. I thought that if I resized the model to a bigger setting, I would be able to see where the problems were. I also just noticed that the model looks fine until I save it and that is when it loses the faces as well. The model is the “knight” from my grandfathers chess set and I am trying to 3d print the whole set. The model is based off of measurements of the actual piece


#15

Scaling up by 100x would probably be enough to work on such a model.
Keep in mind that on the actual piece, the 3D printed object you may lose all the microscopic details anyway. Even though the model can be very detailed. Check what the printer can handle and calculate back what is worth modeling.
I hope you can recover an earlier version of your model to post.


#16

Can I email you the model?


#17

[quote=“kelandrin, post:16, topic:6902, full:true”]
Can I email you the model?
[/quote]You could click on ‘Wo3Dan’ to send me a private message plus attachment. Although I would prefer to see the model appearing in one of your posts here, for all of us to see.


#18

I know but its too big and I don’t know how to make it smaller :frowning:


#19

I dont see where I can send it to you, I clicked on your name


#20

Don’t you see the “private message” option?