Downscaling issue 3d model


#1

Hello fellow users,

I have a problem with scaling.

I have drawn our house including a planned rebuild in sketchup.
It is a quite detailed 3d model and took a lott of work.

I finished te house so far and wanted to ad my landscape.
I used sandbox from scratch and imediately sketchup froze.
I allready found out what the problem was, the house was to big, about a thousend times. :smile:

Now i thought no problem, select all and downscale a thousand times.
It even worked.:ok_hand:

But here’s the key question:
When i zoom in to my model i come to the doorstep and no further.
I am unable to zoom in to detail or even change things.

Can anyone help me out here ?

Kind regards Elzo


#2

You may be dealing with a model that is too large (not meaning the file size).
See if this article about clipping faces is helping you: http://help.sketchup.com/en/search/sketchup/clipping%20plane


#3

Check View/Field of view if is set at 35degrees.


#4

Checked,

No change, unfortunately.

But thanks for the reply.


#5

watched the vid,

There was nothing what changed my issue.

Thanks for the reply


#6

Here’s a copy off my model,

Feel free to try downscaling it by a thousand times and then zoom in into detail.

Basis.skp (546.7 KB)


#7

I’ve deleted these two objects (hidden loose edge, empty Steve component?) and don’t get any clipping anymore.

BUT: The more serious problem will arise from your layers, you have a lot of loose geometry on different layers than Layer0. You should change this to prevent a lot of trouble!


#8

Hello cotty,

Thanks for the reply.
In my model, from which te posted one is a copy, i don’t see the 2 objects ?

The intention of my layers was to be able to switch things on and off.
Can i change this by making a layer a component and put them all in the same layer ?

Like objects in autocad ?


#9

I also don’t see the vertical blue lines on the flat roof and the horizontal red ones by the way.
Is there something that i should turn on in sketchup ?


#10

I’ve turned on the axis for groups and components in the model preferences to make the local axis visible.

To use the layers correctly:

  • model all geometry in the standard layer Layer0
  • make groups or components
  • assign those to different layers to control their visibility
    (the geometry in those groups or components are still on Layer0!)

#11

Hello Cotty,

I have partly solved my rescaling issue.
I had selected all and then rescaled down by 0,001 but i forgot to unhide everything.
now that i selected all including the hidden objects zooming in is better but still not sufficient.
Now parts off the model vanish when i zoom in. ( image )
It’s like a piece of glas cuts trough my view even when i rotate my model, a setting maybe ?

Now from what i understand from your explenation, i am dutch by the way, i should do the following ?

  • When i create something i have to do this in layer zero.
  • i have to turn this creation, lets say the roof, into a component.
  • then i have to assign this component to a layer.

Is this correct ?
I do have a lott of messages like “this face is allready used in another layer”


#12

Oops here’s the image


#13

Just took a brief look at the model.

if you have reduced the model to really small, the geometry will be really far away from the drawing origin.

Then it may cause that clipping issue.


#14

Joseph,

I have reduced the model from Kilometers high to meters high because i created it in a wrong scale.
I thought i was using milimeters but instead i used meters.
After downscaling the model is actually the right size.
So it cannot be to small, we draw actual size, not on scale.

But thanks for responding


#15

You missed @josephkim626 point.
Depending on how you scaled it down it could have moved the model a long way from the Origin.
If it it a long way from the point where the red, green and blue lines meet then that could be causing the clipping you are seeing.


#16

Distance is 10 meters


#17

It would help if you uploaded the actual model that you are having problems with rather than a copy of part of it.
Not much point for us looking at something that may not have the things that you want to fix.


#18

In my fourth post there is a basis.skp file.
thats the object and all its components.


#19

But you then said it was a copy.
I looked at that and i cant see any problems with it except for being very large and incorrectly layered.
So now you have a model with clipping issues. Without seeing it i can’t offer anything more than people have already said.


#20

What i ment offcourse is that i have posted a copy off my original.
if you open the object and zoom in to details there is no problem.
when you downscale by a thousand then the measurements are realistic.
but if you now zoom in into detail this is not possible.

try it and you wil see what i mean.
I am looking for a sollution for that.