Sketchup screen empty (mac)?

Installed trial on MBP 16. Layout opens fine, but Sketchup shows just empty screen. Even after turning off Fast feedback in openGL setting. I can see the tool bars, but the model space is just empty. I can’t see any objects made.

I run SketchUp just fine on an MBP 16" without special settings, so I don’t think this is a hardware compatibility issue. So, questions about other possible things.

What version of macOS are you running (your profile still says Windows 10)?

Did you install correctly by opening the dmg and then dragging the SketchUp icon onto the Applications Folder icon in the installer dialog window?

Can you share a screenshot of how the UI looks?

Screen Shot 2021-07-29 at 3.35.45 PM

Yes I opened DMG and dragged the SK icon to App, just like any other software.
Here are screenshots of Mac and SK UI.

If you click View->Axes what happens?

If you click the pencil tool in the top menu, then click in the blank space, move the mouse, and click again what happens?

This is really strange. I was going to video record nothing happens with pencil or whatever tool. It’s just blank light gray space.
Today it suddenly is working.

macOS/Rosetta updated in the meanwhile?

I’m not really sure if there was any update last night? I typically keep it on auto update so that it’s always up to date.
At least it shows the same mac OS Big Sur version 11.4 today.

if you had shut down the system over night maybe restarting the system has helped.

I’m not sure if there are many MBP users who shut down their laptops. I certainly didn’t, but glad it’s working now. It’s also good to know that you have the same laptop that’s working just fine with SKP.
Thank you.

i don’t owe a MBP, I’m a Windoze user.

You should restart more or less every computer from time to time, especially after updates of the OS.

The latest version of Big Sur is 11.5.1, so you aren’t getting updates the way you thought! But if there wasn’t an update, obviously that can’t be the issue. My MBP 16 is running 11.5.1 and SketchUp 21.1.298.

An update on macOS normally reboots as a step in the install - sometimes reboots more than once. But regardless, you are right that it is a good idea to reboot periodically even if there was no update. These days macOS is sufficiently stable that many Mac users don’t reboot very often. But a reboot clears out various accumulated cruft that both consumes memory or disk and can cause errors.

Oh no. It’s blank again. I updated Mac and rebooted, hoping it’d solve. Still blank.

Here’s a video recording of showing the blank canvas. No matter what I do, nothing is shown.

Okay. I think I found the cause. It’s “Sidecar” with iPad. If I’m using iPad as the 2nd monitor with Sidecar, SKP will show the empty gray model space as shown in the video. It doesn’t matter where the window is located either on MBP screen or iPad screen.

It looks like a bug from SKP which doesn’t recognize MBP and iPad Sidecar function. This is a very useful set up. SKP team, could you please fix this issue?

SKP works fine when iPad is not connected via Sidecar.

I seem to be able to use my iPad as either screen. My MacBook Pro is identical to yours, other than being Catalina. I may try Big Sur, see if that makes it be different.

What is the modeling program in the background?

I updated to Big Sur, and still my iPad seems ok.

You use Sidecar with iPad for a 2nd screen, but SKP works fine? I can’t figure out why, then.
In the background, that’s AutoCAD. It doesn’t seem that AutoCAD is causing the problem. I just tried to open both CAD and SKP, and SKP works just fine as iPad isn’t connected via Sidecar.

this is a OpenGL display output problem. Therefore you shouldn’t run other applications (maybe) accessing the OpenGL API of the display output pipeline as e.g. (3D) CAD applications or remote desktop applications etc. at the same time for evaluating the issue.

Multi monitor setups, especially if using different screen resolutions or placing the external monitor logically below or left hand from the main monitor (= negative screen coordinates), are prone for this error type. Check too, if the MBP is powered by the Radeon whereas the Sidecar/iPad is delivered by the integrated intel HD… which might cause issues too.

The question is, @colin seems to be using iPad via Sidecar and SKP at the same time without a problem? I tried eliminating all other causes, and that’s the only one left.

I could use AutoCAD and SKP at the same time without a problem. I could also run remote desktop application and SKP at the same time. The only time it doesn’t work is when I connect iPad via Sidecar. It’s such a bummer as I use it all the time when I need to work on MBP 16.

I tried with my iPad on the left, right, above, below, also while running a Remote Desktop session on iPad or main monitor.

Just thought of one thing, I currently am driving another external monitor. I will try with only the internal LCD screen and the iPad, see if that makes a difference.

BTW, in the system report it doesn’t list the Sidecar display, it only shows the other external display as using AMD, and nothing is using Intel. That may change when I do the test without the external monitor.

I found a combination that shows a problem, and a work around for now.

If you open SketchUp and send the document to the iPad, while the iPad is a separate screen, updates to the model window don’t happen. Your actions are being seen, but the model doesn’t look any different.

If you turn on Mirror Displays, then naturally it starts to work. When you turn off Mirror Displays, it continues to work.

I will show the issue to the developers, and see if anyone has an idea.

Update already. One of the developers was seeing the same symptoms when using a Dell as a second monitor, so the issue may not be iPad or Sidecar related.