Sketchup screen empty (mac)?

Thank you. At least a developer witnessed the issue him/herself. Hopeful it gets fixed soon before my 30 day trial ends, which I haven’t been able to utilize with iPad sidecar.

However, I’m not sure what you mean by the workaround. Are you saying there is a way to use SKP on both MBP and iPad screen currently?

Yes. In Displays, Arrangement, check the box for Mirror Displays. You should now be using SketchUp ok, and seeing it on the iPad as well. Now uncheck Mirror Displays, and the SketchUp window should continue to behave correctly.

do they use the same screen resolution?

I have found out since that the issue may be more to do with which monitor is the primary one. A developer sees the same issue with a docking station, where he has the internal MacBook Pro screen, and an external portrait monitor. SketchUp opened up on whichever is the primary monitor works fine, but if the window is dragged to the secondary monitor the updating stops working. I think the same is true for AirPlay screens.

In both of our cases the two screens are very different resolutions.

OpenGL is not a simple thing…