SketchUp Scene Crashes - New Thread and Update. Still Crashes

Hi All,

I posted a week or so ago about crashes in SketchUp 2023 when exporting an image from a scene and immediately switching to another scene. This would cause a crash. I managed to get it to fail pretty consistently once I knew how to replicate it in files. Using the eye or any other camera movement tool will prevent it from crashing if you use that before switching scenes.

I believe I have hunted down the culprit. Not sure what windows version people are running, but I’m on Windows 11 Pro, with SketchUp 2023 Pro. The most recent windows update does not fix this, but the Windows Installer Service is not automatically activating, which is preventing certain functionality somehow. I’m doubt that’s causing the crashes in the software, but it could create a failure in the install that would prevent you from repairing it. The SketchUp2023.msi file disappeared and I was forced to reset my PC because I could not repair or uninstall the software.

I have activated the windows installer package just now and it’s installed a new SketchUp2023 version over top of my old one without asking for a repair. So it’s like it wasn’t ever truly installed in the first place. Super weird. The software is still crashing so I don’t know what to do next. Maybe I’ll try repairing it this time with the install service active and hopefully it works.


1 Like

Update to the Update. 2023 is still crashing, but I was able to repair the install with no issues, so the installer package issue is fixed. I’m not sure what else I can do.

1 Like

Is your PC a name brand or a white box?

PC specs are:

Dell Alienware Aurora R15 2023 - purchased at the end of March 2023 (less than a month old)

Windows 11 Pro - 10.0.22621 (Build 22621)


64 GB of RAM

RTX 4090 GPU (driver dated as of 4/18 because of the reset. I can download the 4/13 driver to try and test it out)

crashes don’t discriminate between local or cloud files, nor by file size or geometry stats. I can replicate it every single time if I export a jpeg from a scene, and then immediately click another scene. If I move the camera with pan or eye tools it will not crash.

Sketchup build is 23.0.419

Could try setting your Nvidia card to run SketchUp.

Nvidia Control Panel → Manage 3D settings → Programs Tab

Some links in this thread (scroll down): How do I force Sketchup application to use my NVIDIA Card - Technical Problems - SketchUp Community

1 Like

That does not seem to have worked. I opened Nvidia control panel and set the global settings to quality. Then went to SketchUp specifically and went through all the settings, setting it to whatever the Nvidia icon was on - which I guess matches the global setting.

Still crashes

This is the key setting,Also set it on the programs tab.

Thanks - set it to use the 4090 and it still crashes when trying to export

What happens if you wait a bit for the export to complete?

Here’s a video of what I’m experiencing. I finally went to the only other windows user here and asked them to install SketchUp2023 and they can replicate it on their machine with a fresh install. Same constraints - clicking or moving before clicking the next scene tab prevents the crash, but if I export and click on the scene tab it will crash. I can replicate it here on multiple machines, so hopefully this is replicable on other machines. SketchUp support has several sets of information at this point.

I even opened a blank file to test. First instance you see is the issue - crashes after exporting when switching to a new scene. Second instance is Moving the camera or any other action will prevent the crash. And Third instance is animation still being turned on apparently prevents the crash as well. I went back to the first instance and turned animation back on in Model Info and it’s not crashing. So that must be it. Something is hinky with the software when scene animations are turned off.

I am using 2023 on Win 10 with no issue exporting a 2d jpg. I wonder if this is a Win 11 thing?

Could be. Are you testing with the Scene Animations turned on and off? I also have the super most recent SketchUp version. I feel like this has only been an issue for the last couple of weeks. They did patch the firewall issues out so that may be what’s causing this - a side effect of the bypass or something on Windows 11

Just tried, Win 11, os drivers and SU are up to date. I opened a file with scenes, exported a jpg, immediately changed scene. no crash.
same with a png.

and I first tried with the basic 23 version (I hadn’t updated it yet), same, it’s all ok.

Same, version 531,68 18/04

I’m on a i5 11400H - 2,7GHz
RTX 3050 GPU
32Gb Ram

Could it be the file itself ?

Like, if you create a new blank file, draw a few cubes, create a few scenes, does it crash as well ?

Just for grins, Windows has a memory tester. Run it and let us know the results.

Are you using extensions?

I am 23.0.397, looks like they snuck in an update. Will try exporting again in a bit.

Edit: With the .419 version on Win 10 I experience no issues with the export.

crashes in a fresh install - so no plugins installed yet beyond default sketchup.

I did that too for giggles - and it crashes in a blank file as well.

yeah let me know if you can update to 23.0.419 and see if it’s still a thing. Only thing I can narrow down is scene animation settings being the cause.

are you scene animations turned on?

Scene transitions is checked with the time set to “0”.
Animations is also checked

I just installed .419 still no issues…Win 10.

Have you run the memory test yet?

both, I tried with and without, I tried jpg, png, tiff, i tried clicking straight on the tab, and double clicking in the scene panel.

it’s a mystery.

Did you send one / some of the bugsplats post crash ? so the devs can have a look at the entrails of your problem ? (fill it completely, with contact address and all, it’ll make it easier to find you)

I’ve sent like 20 lol

ran the test and no issues were found