Abrupt and unprovoked crash in Trial version

Hi there,
Today I finally decided to test run the Sketchup Pro version.
So far it has been enjoyable and refreshing (been using sketchup free for a few months and recently upgraded to the Go version).
All went well until a rather bizarre crash started to happen.
I’ve opened a few projects I’ve made on the web version and when I started editing and switching Scenes (mainly using the Tray) the software crashed and the Bugsplat window appeared.
It happened in several projects.
No extensions were used, GPU driver up to date, windows machine up to date.
and obviously - most recent Sketchup version.

I fear this would gobble up my 7-Days evaluation period without really experiencing the software :sweat_smile:

Has anyone else been experiencing any instabilities with recent version of Sketchup?

P.s
My computer specs:
I7 12700H
RTX 3050
16GB DDR5 4800Mhz

Hope the solution appears before the trial expires haha

Thanks,
JOTH

  1. Make copies of your files before opening them in SketchUp

  2. In SketchUp, go to: Window > Preferences
    switch to the General panel
    check both options under Check for Problems

  3. Perhaps increase the AutoSave interval or disable it
    Same panel in Preferences


When you restarted, did you see your file thumbnail with a red RECOVERED banner on it?

did you send the bugsplats ?

if so, Colin and the devs (band name right here) can have a look at what’s exactly crashing.

I haven’t been experiencing those crashes on PC or Mac, can you share a file you’re having issues with so we can test it to discard a file issue?

Have you tried to create an empty file and provoke the crash?

Hi Dan!
Followed your suggestions, issue persists.

It did appear several times but not after each and every crash…

Yes I have, a few of them!

So, I have tested it on variety of projects I’ve made (also one I did not make sent by a friend), they all share the same crash.

I have done so just now!
Same unfortunate result :expressionless:

I have no idea what might be the causing factor.
Hopefully this is resolvable but simple means.
I am not entirely sure if this could be related but my PC has been through optimization for Music Production applications, I am not sure what SketchUp defaults to but some crucial settings have been changed in order to accommodate the DAWs’ (Music Softwares) needs.

Not entirely sure it would help but I could share the changes made for these software to work “optimally”.

Thank you all for the effort, I am hopeful the solution would come quickly before the expiration date :joy:

As a sidenote, why did SketchUp shortened the Trial period to a week instead of the much more reasonable month?

Okay, when you installed SketchUp, did you right-click the installer and choose Run as administrator ?

If not, then restart your computer if you have run SketchUp this session, then find the installer executable, and right-click Run as administrator, and choose the Repair option.

It’s a crash in your NVIDIA driver. Check it for updates, and if there are none, consider rolling it back.

Google “nvoglv64!DrvPresentBuffers” and you’ll see that the number of software applications that crash because of this.

b

2 Likes

Hi Dan, well… this is kind of an automated action I am doing when installing a software (years of doing that - ensuring that each of my highly demanding music related software and plugins would work properly).
I will try to re-install it for the sake of certainty.
Thank you!

Hey Barry!
Thank you for your response!
Well the odd thing is that I have tried installing the software on my studio PC (which is a completely different machine).
It happened there as well!
The other computer is an offline machine so the procedure of sending the Bug Splat report would have been a little more complicated for me (when authorizing/licensing I am connecting to the internet via a personal hotspot :sweat_smile:)
I will test it again on both and will try to follow your suggestions… fingers crossed! :crossed_fingers:

I am adding here a small clip showing what is happening.
Apologies for the lack of a cursor, noticed that only after exporting.

Switched my GPU to the Intel integrated one (set as default), made sure everything is up-to date, re-installed Sketchup (Run as Administrator)… issue persists :man_shrugging:
Clueless by now.

Feel like I am obligated to keep using the web-based versions haha
Such a shame, been very excited on testing Layout for some documentations and plans.

I recently had weird crashing issues for files that did not crash for others and crashes upon opening any file from the recent links at the bottom of the File menu.

@colin had me (with SketchUp closed) delete or rename the PrivatePreferences.json file at:
"%LocalAppData%/SketchUp/SketchUp 2023/SketchUp" and restart SketchUp.

The JSON file was regenerated with factory defaults and the weird crashes ceased.


Your video seems to show the crash immediately following adding a new scene.

Does this also happens when you don’t rename the section name and symbol?
You named it ‘B’ but the symbol shows ‘F’
What region settings do you have in Windows?

I understand, well I have decided to start fresh and remove any trace of SketchUp from my computer - closest to re-formatting it (appdata/hidden folders/registry etc…)
Once re-installed the software (prior to testing the new clean installation), I’ve been prompted with a suggestion to update to a newer version.
Been working for a few hours now… not a single crash :man_shrugging:

So, I am not sure if the complete removal was the solution or was it the update… either way it appears to work now, and without any hiccups…
Good enough for me!

It did happen with or without naming or renaming.

Last time I checked, “Everywhere else / Rest of the world”
Would that change anything?

Regardless,
I would like to thank everyone here!
You were all very helpful and i appreciate it!

Joth

1 Like

So, then you were having issues the whole time and not yet running v 23.1.340 ?

  • The very first “fix” on the list for release 23.1.3 is:

    • (Win) Fixed a crash that could occur when changing scenes while Scan Essentials is activated.
  1. Where did you get the installer the first time ?

  2. If you do not have a laser scanner and are going to use point cloud imports, then you should deactivate the Scan Essentials extension in SketchUp’s Extension Manager.


BTW … your profile is still incorrect as v 24.0 has not yet been released.

Hey Dan!
I downloaded it via the official SketchUp website!
Just three days ago!
the update appeared only today… so I had no notion that the particular bug was prominent in the previous version.

and I will do so!
I am quite new to the Extension possibilities (besides lurking at the endless options on YT)

HAHA it appears that people around here are taking the profile info quite seriously, I shall revisit there now.

Thank you again kind sir!
Joth

Yes we do because what is in your profile effects how we can answer questions and diagnose issues.
How to do something can be different in the web version to the desktop version and even different years, different mac to pc and graphic cards point to potential resolutions and so on.

Having to ask all these questions each time before you can even address the question posted is somewhat frustrating.

4 Likes

duly noted, I will keep this updated.
Thank you!