SketchUp 2023 Crashes After Exporting Image and Switching Scene

Hi All,

I’m suspicious of my 2023 install. Got a new computer and of course the Windows Firewall blocked everything until I turned it off and SketchUp 2023 has been crashing, pretty consistently, when I export an image and then immediately switch the scene.

  • Export to 2D Image > Switch Scene > Crash
  • Scene has had style changes
  • Sometimes waiting doesn’t cause the issue or saving before hand so I at least don’t lose work
  • Doesn’t matter what file it is

Anyone have any ideas?



When you installed SketchUp 2023 did you right click on the downloaded installer and choose Run as administrator?

Can you share a SketchUp file that exhibits this problem?

This was proven to be a problem with the Windows security stuff, not SketchUp andWindows fixed that a week or so back.

I’m pretty sure I ran it as admin. I remember seeing SketchUp stuff about it - and the Windows Security system was labeling it as a trojan or something.

Here’s a a file with the branding stripped out since it’s an active project. This is the file that crashes the most consistently. It’s a WeTransfer link since the forum has size constraints.

It wouldn’t hurt to close SketchUp, find the installer, right click on it, choose Run as administrator, and then Repair. Also check with Nvidia to ensure you have the latest graphics drivers installed. I’ll see what I get with your file an exporting images. What file type are you exporting? What size?

Nice looking model. I’ve successfully exported images from Natatorium 1, 2, and 3 with no crashes.

BTW, I see a bit of incorrect tag usage …
Screenshot - 4_18_2023 , 11_33_44 AM
… some stuff to purge …
Screenshot - 4_18_2023 , 11_34_02 AM

… and some excessively large texture image. After dealing with that stuff I saved the file. File size was reduced by more than 30%.

Thanks Dave. The large graphics are due to other designers working on this file. I built the starting model and then a few other people have worked on it since. I’m coming back around for some donor renderings. I usually run cleanups and material resizing when I can but I’m on this new machine and don’t really have to worry about slow downs as much as the others.

I’ll repair my install and hopefully that will help.


1 Like

Update to this. It’s searching for a “Downloaded Installations” file that’s a long list of letters and numbers and it can’t find it. Do I just need to just uninstall completely and reinstall?


You shouldn’t be getting that message. Cancel that and download the current installer again from Download All | SketchUp Then right click on it and choose Run as adminstrator and Repair.

That’s what I did. It’s getting this message regardless. It won’t let me uninstall either because it can’t find the package. Can’t find the file either - even if I manually type in the file address it’s trying to find.

Maybe @colin can suggest an alternative.

Thanks. This is the file it’s supposedly trying to find. Won’t let me repair or uninstall until I find it, but I can’t find it anywhere


Another Update. I can’t open SketchUp at all now lol

that’s weird, looks like you don’t have access to it, or at least that the insaller deamon is not there.

are you working on a network ? is SU installed locally or on the network ? since you mention that other people work on your files

The individual SKP files are network - Dropbox - but the install is on my local drive. This PC is only a few weeks old - it’s a new Alienware Aurora. Would this be a Dell thing?

Best practice is to save and open SketchUp and Layout files on a local drive only. If you must, after saving the file upload it to the cloud, then when wanting to open the file download it to the local drive, then open it. All my Sketchup files are saved on my PC only.

Yesterday I had to reinstall sketchup again, I have windows 11 pro, I ran the installer as admin and I didn’t even have to turn off the firewall. Just installed it and used immediately.

Noted. The networking file saving thing has never been an issue for me. It’s just the crashing has evolved into me having to reset my PC lol couldn’t remove SketchUp or repair it so I just had to brute force it

I just tried your SU file on my new Dell XPS and no issues at all. Just to see if it is a “Dell” issue as mine is a new Win11 Pro SU Pro 2023 install.

Yep. I heard that had been patched. Something about the .msi file got deleted and I had to do a full reset because I couldn’t remove it without it. Couldn’t repair it. Etc.

I think you’ve been lucky. Might want to buy some lottery tickets. Working on files directly saved in the cloud has caused a number of users to have corrupted files.

Does SketchUp crash is you first save the file to your internal drive and then do the image exports? I noticed with your file that after a couple of the image exports there was a second or so of delay while a save was being performed. If that happened while waiting for DropBox and you changed scenes, I could imagine Sketchup might crash. BTW, are you getting Bug Splats when SketchUp crashes?