Bug Splat on Scene Change

I’m using Sketchup Pro 2023, it has been working just fine until recently. I open a drawing, I do nothing else but try to change the scene and I get a bug splat. It doesn’t seem to matter if it’s a 33MB file or a 330MB file. I have the most updated Nvidia video card driver installed, I already tried reinstalling it. I have Sketchup set to use the Nvidia video card not the default Windows 11 video processor. My computer build is as follows: AsusTUF Gaming Z690 Plus wifi MB, Intel Core i9-13900KF processor, PNY Nvidia Quadro RTX A5000 24GB DDR6 video card, Samsung 990 Pro SSD 2TB, Seagate Ironworld 3.5 SSHD 8TB. Thanks for any suggestions.


Hmm well, we can’t really give you a magic answer right now, so here are questions :

  • have you correctly send the bugsplat ? some people see it and dismiss, but you actually need to fill it out and then send it. If so, colin might have an idea of what’s going on just by looking at it, and if it’s an actual SU bug
  • could you share a problematic file with us ? so at least we can rule out file error
  • is it only old files from 2022 that you pen in 2023 ? I mean, if you open a blank file, create a pair of scenes, will it crash too ?

There was an issue when switching between scenes when Outliner was open, which was fixed before 2023 was released. Can you see if closing Outliner makes a difference to your case? Also, do the scenes feature changes of section planes?

Those aside, can you show a small model that crashes every time?

What? No magic answer? I jsut recreated the situation and sent the bugsplat.

How would you rule out file error? The file is 156mb, I’ve had this issue with smaller 33mb files and larger 360mb files.

I have not tried to create a new pair of scenes.

Not all users have had this issue. I saw a report from someone yesterday who was experiencing something similar but when I and another user looked at their file we couldn’t reproduce it. Could you share your 156 Mb file so we can examine it and see if we can determine what’s going on? It would be too large to upload directly so upload to DropBox or similar and share the link.

I don’t use outliner, and don’t have it displayed in the tray. The scene I’m attempting to change is between main and upper floor plans.

When I open the file, a floor plan is the last scene the file was saved as, as soon as I try to change scenes it bugsplats.

Here’s a link to the file:


I tried some other functions, I can rotate the model, I can move objects, I can turn tags on and off, but as soon as I try to change to any scene it bugsplats.

I will try to save as a differnet file name to see if that makes a difference.

Same result filed with different name.

1 Like

No bug splats for me. First things I did though were to fix incorrect tag usage…
Screenshot - 3_15_2023 , 11_45_30 AM

And purge unused stuff.
Screenshot - 3_15_2023 , 11_46_39 AM
Looks like a candidate for a hoarders TV show. :smiley: Purging the unused stuff reduced the file size by a little more than 78%.


Well, if losing weight was only that easy! I will purge the file and see if that takes care of the problem.

I know! I keep looking in the pantry for a Purge button but all I find is Girl Scout cookies and chips.

Here’s a link to the model I purged. You’ll probably want to create a tag for the driveway group. BTW, I fixed the plan scenes so the camera is in the same location for all of them. That will make aligning viewports on sheets in LO easier.

I purged my file, dropped the size to 44MB. I purge my autocad drawings all the time, it never crossed my mind to purge my sketchup models.

It is still producing the same issue. I will download the file you purged and see what happens.

Had the same issue with the file you purged. Maybe it is time to reinstall Sketchup?

If you do, make sure you do so correctly. Right click on the installer and choose Run as administrator.

You also might try deleting the heavy tree components and purging them from the file. See if that has any impact.

OK, I don’t typically have the scene tabs open, I change scenes from the default tray. I noticed you changin scenes with the tabs so I tried that, I can change scenes with the scene tabs, but get the bugsplat when changing scenes in the default tray.

That works fine for me, too.

Purged the file and got it down to 44mb file size. Able to change to all scenes with no issues. using 2022 Pro.

By the way, when I purged it the file was reduced to 31.8 Mb.

FWIW, I did much the same as @DaveR but on my Mac, and I also don’t get crashes when changing scenes. You might not have realized that just the “Oak Tree by International Treescapes LLC” component(s) contribute more than half of the geometry in the model! They make for pretty renders, but are really loading the model down.