SketchUp runs slowly

Hi. I have a problem with the smooth running of the program. I recently changed all my PC hardware. I have now:

  • AMD Ryzen 9 3900X processor, 3.8GHz, 64 MB, BOX
  • MSI GeForce RTX 2060 SUPER Ventus GP OC 8GB GDDR6 graphics card
    -2x Patriot Viper 4 memory, DDR4, 16 GB, 3200MHz, CL16.
    I also changed Sketchup to the newest one. The system (Win 10) was the same. Do models have the right to walk slowly on such equipment? Before, I had:
  • Intel Core i7-6700, 3.4GHz processor
  • Gigabyte GeForce GTX 970 4GB GDDR5
  • Kingston HyperX, DDR4, 16 GB (2x8GB).
    What can I do to increase the program’s performance? Thanks in advance for ideas :).

You omitted important information: How heavy is the model file that feels slow to you?
When the edge/face count, including components, runs into millions, zooming and orbiting become very noticeably slower, whatever the computer hardware.

SketchUp, like all 3D modellers, is a very CPU-intensive single threaded application. I compared the Passmark results of the puny i7 processor in my new ultrabook and your AMD one, and while in total yours scores more than 4 times more than mine, their single thread performances are very near each other, mine only about 10% slower.

2 Likes

See for example:

Be particularly careful using models from the 3D Warehouse for ‘entourage’. They are often grossly over-detailed, with very high edge counts, far too many segments in arcs and circles, and may use large textures.

And when modelling, work in Face Style/Monochrome, using a simple Style, with Profile edges turned off for faster redraws when zooming or orbiting.

Hide what you don’t need to see while modelling, by turning off visibility layers/tags.

Using such techniques, and reasonably powerful hardware, you can work on models with millions of edges, tens of thousands of component instances, and model file sizes in hundreds of MB.

2 Likes

Thanks for the answer. The files weigh up to 700MB. I try to make components, clean unnecessary elements and turn off the display of shadows. But the fact is, the models I download are heavy.

Thanks for the link to the page - these solutions apply.
But I did not use the solution with a monochrome texture, I will definitely try it out. Thanks

700MB sounds massive, what’s the poly/component/face count on those models? What size are the textures?

Tried cleaning them up with Material Resizer, CleanUp or Skimp?

1 Like

If you are getting a lot of models from the 3D Warehouse, and they are overdetailed, then you may need to simplify and/or redraw them.

Or be more selective and choose lighter weight models.

Here’s a post I wrote some time ago that might help you.