Sketch up run slow with ryzen 1700x config

Hi there,

I’ve build a new pc with 16gb ram , ryzen 7 1700x , an asus 1080. I have some issue with sketch up. It run slow. I think is not fully supported by the software since in the spec I see only intel CPU. Is there any drivers or configuration ???

Thanks

Don’t you mean Intel GPU? Your CPU is by AMD.

So you computer doesn’t see the GTX graphics card? Did you install the GTX’s driver? Is it not listed in the device manager?

One clue to why your CPU is perhaps not the greatest for SketchUp:
https://www.cpubenchmark.net/singleThread.html

You are perhaps overestimating what hardware can do. Models with milllions of edges or faces run slow, whatever the hardware. SketchUp is a single threaded application, and when you zoom or orbit, all the geometry is processed by the CPU while your GPU (graphics card) takes care of textures and shadows. That is why investing in an expensive graphics card is overkill for SketchUp.

Does your AMD MB like using NVidia graphics? Does it have adequate specs to run a GTX 1080 if the AMD board will run NVidia graphics?

So I have to change the mobo and the CPU cuz amd ryzen is not good enough?

My bad :frowning:

No. You just have to model smarter. My very old i7 scores 1228 versus your 1876 in the passmark single core test, and it works quite OK with my small models. My similarly old video card scores 583 vs.12150. SketchUp problems cannot be fixed with hardware.

In SU, what graphics does it report you are using? Go to Window > Preferences > OpenGL > Graphic card details.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.