Sketchup 2017 unusably slow with skylake I7 6700K and GTX 1080

lag
slow
processor

#1

I have used sketchup for years and some times on very low end systems yet it always worked very well. I just upgraded my PC and now Sketchup is unusable with how much it laggs. I am a big DIY guy and always plan my projects and material lists with sketchup so I would be pretty sad to lose its use with my new computer. Has anyone else had trouble with SkyLake processors or have any idea what to do. I’ve tried running in compatibility mode and the graphics option in sketchup seem very limited.

My System:
windows 10 PRO
Intel I7 Skylake 6700K
Nvidia GTX 1080


#2

ensure with the nVidia Control Panel that SU is not running on the integrated intel HD/Iris of the CPU but on the dedicated GeForce:


#3

Thanks for the help sketch3d_de,

My options were a little different because my MoBo doesn’t have onboard graphics. Because of this the option of which graphics processor to use doesn’t exist, however I followed your instruction anyways and added sketchup to the program setting list and ensured everything was set to “use global settings” (which was the default), then gave it a restart for good measure and now its working great.

It’s funny because I don’t feel like I actually changed any setting but I cant argue with results, Thanks for the help.