Sketchup Too Slow To use

slow
help

#1

I have recently got a new laptop for my Product Design A level its a decent laptop with an i7 quadcore @2.6Ghz, NVIDIA GeForce 960m 4Gb VRam, Windows 10 64Bit , 16GB Ram with an SSD and HDD. It runs programs like photoshop and illustrator well and games very well. However it is unsable for sketchup, the toolbars are fast but as soon as I try and draw a select box, draw lines or even rotate the view it takes ages to do any of it. I have tried Layout which works fine and is very fast its just Sketchup Make.
I have tried different versions of sketch up 2017 & 2016, 32Bit & 64Bit, running them both in windows 7 and 8 compatibility modes. I have also checked that its the Geforce card being used and not the integrated one.
While attempting to use sketchup make task manager shows that nothing is under much stress, the cpu and disk levels are fine barely used, the RAM maxes out at about 3.2GB.
I have tried everything I can think of with no success Just wondering if anyone had any more suggestions.
Many Thanks, Dave


#2

• any plugins/extensins installed?
• latest nVidia GeForce driver of notebook maker installed?
• 3Dconnxion Mouse? -> install latest driver
• on accu or AC/DC resp. any power saving active?
• internal display or external monitor?


#3

This sounds like a memory leak.

Since it happens in any SketchUp version or bitness, I’d suspect device drivers. Update them all, and disable any devices you don’t use. (Example I never use touchpads, so I always disable them.)


#4

Updated Geforce drivers which came out very recently and its fixed the problems thank you so much :smiley: