Select tool takes forever!

Hi I’ve just bought a new laptop spec as below
OS: Microsoft Windows 10 Home 64-bit Ver.1703(OS build 15063.0.amd64fre.rs2_release.170317-1834)
Windows Product Key: PKCHF
HDI Build: ZS7-1795RM4-IS3 3.0.A40.29.0.1
BIOS Version: E1795IMS.305
BIOS Release Date: 2016/12/15
EC Version: 1795EMS3.1060307201610:58:34
CPU: Intel® Core™ i7-7700HQ CPU @ 2.80GHz
Memory: 16 GB @ 1066 MHz
- 8192 MB, DDR4-2133, SK Hynix HMA41GS6AFR8N-TF
- 8192 MB, DDR4-2133, SK Hynix HMA41GS6AFR8N-TF
Graphics: Intel® HD Graphics 630, 1024 MB
Graphics: NVIDIA GeForce GTX 960M, 2048 MB
VBIOS Version: 82.07.94.00.1c,2097152
Drive: SSD, TS128GMTS800, 119.24 GB
Drive: HDD, WDC WD10JPVX-22JC3T0, 931.51 GB
Network: Qualcomm Atheros AR8171/8175 PCI-E Gigabit Ethernet Controller (NDIS 6.30)
Network: Intel® Dual Band Wireless-AC 3168
Network: Bluetooth Device (Personal Area Network)
SHIFT mode: SportMode
Power Plan: Power Scheme GUID: 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c (High performance)

Using a trial version of Sketchup Pro 2017 in conjunction with VRay as a plugin.
The selection tool in Sketchup will not operate correctly, it takes about 10 secs to pick a single line.
( very annoying and useless ) There have been I’ve noticed a few threads about Windows 10 and updating drivers ( which
I’ve done ) but nothing very recent. I just got the laptop and from what I can gather I think is was assembled end March 2017.
Has anyone please got a fix for this (before I send it all back to the supplier ).

Thanks !

Have you checked the nvidia control panel and SketchUp 's preferences-> open gl to make sure SketchUp is using the nvidia not the integrated graphics?

Hi
I checked and yes it is using the integrated graphics and not NVidia.
Stupid question how do I switch it around?

I’m not sure if the instructions from this link can help, but according to it.

  • Open the NVIDIA Control Panel.
  • Click the Manage 3D Settings link.
  • Click the Global Settings tab.
  • In the Preferred graphics processor drop down menu, select “High-performance NVIDIA processor).
  • Open the NVIDIA Control Panel.
  • Click the Desktop menu from the menu bar.
  • Select Add “run with graphics processor” to Context Menu.
  • To use, right click on the program or shortcut and select the graphics processor to use.

That would mean that once it’s done, you can right clic on the SketchUP excecutable and select your graphics card.

Update, I muddled my way through Control Panel etc and swapped it over.
Result, it worked !!
Many thanks, I’ve saved what remains of my hair…

Cheers !

@gareth50

I’m not sure if you changed the graphics adapter for the whole system.
As far as I know If you do that on a laptop, the battery will drain faster and in a unecessary way because the dedicated graphics card is working all the time, instead of only using it when it’s required, for games, for 3D designs and so.

Hi
I changed it for the graphic card only in the NVidia Manager program.
It gave the option of picking the programmes using the graphic card.
In this case Sketchup.
Hopefully that’s ok and won’t affect anything else?

It looks like the right way to me but I’m not an expert.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.