Sketchup Pro - file unusual slow

hello everyone, currently I am experiencing a strange problem in SU-pro. A file in which I work shows strange behavior. When I open it, it works fine to work in, but a little later everything goes very slowly. It is a small file, only 415kb. The strange thing is that other SU files work just fine, even a much heavier file of about 49Mb. I cleaned up the file completely. Unnecessary layers, layers and materials have been removed. File checked by SU, no problems were found. In model info are: 2 Edges / 13 Component definitions / 10 Tags / 7 materials / 1 Styles / 3 Tag folders. I can’t think of anything else why this file is difficult and the first few minutes just work well. Anyone have an idea/suggestions ?

See what Model Info>Statistics shows when you check the "Show nested components " box. You can also post the file here so others can take a look.

hello Anssi, thank you for your quick response. In ‘show nested components’ are: Edges 97992 / Faces 42450 / Component Instances 657 / Groups 294 / Component definitions 13 Tags 10 Materials 7 / Styles 1 / Tag folders 3. Here also try to remove the unused ones, but they are not there. Also no problems found.

Have you installed any extensions?
Where are you saving the file (on your own disk drive or to a cloud storage service)?
Is Autosave turned on or off?

… I work in the file from a hard drive in my PC. So not in the Cloud. I always have Autosave on, every 20min. Can turn this off once, but this was never a problem… Incidentally, the file has just been reduced to 389kb after closing. I will upload the file…Burgum, boekhandel-Burgum-ontwerp-kaartenmolenvlonder.skp (388.3 KB)

If this file is running slowly on your computer I would suspect the graphics card. Try turning off Profiles in the style and see if it plays better.

Did you “purge” Components, then materials.

There is this other thread with a similar sounding problem. I wonder what’s up.

… just turned off the ‘profiles’. And it seems that this was a problem. The file is now working smoothly again. When I turned the ‘profiles’ back on, it seemed as if the file was getting a little slower again. Go and try it out… If it turns out that this is the problem, I am in any case helped, although I wonder why ‘profiles’ can suddenly give such a problem in such a light file. First thought of the graphics card, since it is already starting to age. But with other, larger, files, this does not cause any problems. I don’t know in what order I cleaned up components and materials, but I can’t currently clean up any materials in this file, so all still existing materials are in use…in your proposed topic I immediately find no other solutions than already known and done. As for extensions, I use: 3DxSketchup (3DConnexion - 3D mouse) / Advance Camera Tools (SU) / Dynamic Components (SU) / M Moser Camera Clipping Fix / Sandbox Tools (SU) / Selection Memory / Skalp / Solar North / Su Podium V26…

Having Profiles turned on doesn’t cause me any problems on my computer. Profiles do work the graphics card harder. Display of those profile edges is another thing that the graphics card has to process. The fact that you are seeing a difference with them on and off indicates that your graphics card is struggling with them turned on.

hello DaveR… that’s interesting information. Didn’t know that ‘profiles’ can have so much influence on the graphics card, Will try this out with a much larger file… To be honest, my PC is getting old (7 years) and the graphics card needs to be replaced. But because of the age of the PC, I can’t just only replace the graphics card and actually need a completely new PC. However, due to the Corona crisis, I had to wait a year and, yet, could not afford a new PC… And in principle, it went pretty well so far, although at times I notice that the PC runs into its top… In the meantime, I have been working with the file again and it seems that ‘profiles’ were really the problem :smiley:… thanx to Anssi and DaveR :+1:

1 Like

It’s worth looking at the style thumbnails. The ones with the little green stopwatch icon are “fast” styles. Here is the default Hidden Line style.
Screenshot - 11_18_2021 , 1_46_44 PM

Turn on Profiles and it’s no longer a “fast” style.
Screenshot - 11_18_2021 , 1_47_01 PM

The edges that are displayed as profile edges depend on the view of the model so that’s more calculating to do especially as you making camera position changes.

… look, I’ve been working on SketchupPro for many years, but every time you learn something new, especially when you run into a problem… I never knew this and had never noticed it… thanks DaveR, very useful information…

1 Like