Slow sketchup file

Hey ya’ll, I have a sketchup file thats slowing me down right now at work. I’m on a brand new PC and the file is only 7,446KB. Would anyone be willing to open it up for me and see what the issue is? Whether it’s my PC or something wrong with the file.

Please upload the file.

D.A.V. 4.skp (7.3 MB)

Turn off profiles in the view: edge style will make a huge difference here

1 Like

yay that worked!! thank you. hopefully it doesn’t slow down again.

1 Like

Some of the materials are very large, but even with Profiles turned off, and materials reduced in size, the model still performs slower than you would expect.

1 Like

It shouldn’t if you maintain control over the model. The main reason for the slowdown, as Eric alluded to, is the large number of profile edges that needed to be accounted for. The bulk of that comes froom your rails. It would also help to keep your model close to the origin. As it is, it is located a long way from there.

I moved it to the origin and also fixed incorrect tag usage and purged unused stuff from your file. File size reduced by more than 60%.
Screenshot - 8_1_2022 , 1_41_34 PM

D.A.V. 4 moved.skp (2.7 MB)