Sketchup Pro 2016- Generate report 2.0 not working

2016

#1

Hi

I recently installed sketchup Pro 2016. Apparently the generate report feature was upgraded for this version. However, I see no difference from the “generate report” feature in Sketchup Pro 2015. I am still unable to customize the reports.

Is anyone else having the same problem? Any Solutions?


#2

You need to be online to access the new Generate Report feature. Are you connected to the internet when you try to run Generate Report?


#3

Open browser (IE/Safari depending on PC/Mac) and go to https://3dwarehouse.sketchup.com/generatereport_v2.html

What do you get?


#4

I sometimes work offline. Why is an internet connection required to use this feature?


#5

Hi Barry

Thanks for that. Yes, my PC did have full internet connection when I tried using the generate report feature.However, I’m still not sure how to make this work. The link takes me to a generate report webpage with some options to make custom report templates. There is a button that says “save to model”, however, when I click that , it appears to do nothing.

How do I use this link to generate a customized report for my sketchup model?


#6

The code which formats the report is loaded from SketchUp servers. This allows us to improve and push new features whenever, instead of having to wait for major releases.


#7

Our help department is backed up with articles to explain. I’ll try to dig up something I can share. @Theo, if you notice your model, it’s now marked as changed, and the template for your generate report is stored with your model. You should be prompted to save when closing, even if you didn’t otherwise modify the file.

@slbaumgartner, as @TheOnlyAaron mentioned, the new generate report is better because we keep it online, IMHO, and deliver updates, as we’ve already done once this week post 2016 launch. If you’re not online, you’ll revert to the old generate report, which had both an online and offline portion in earlier SketchUp versions.


#8

You’ll find a description of how the new Generate Report 2.0 works in this article on the Knowledge Center: http://help.sketchup.com/en/article/3000128

Be sure you’ve selected SketchUp 2016 as the version in the version picker in the top right corner.


#9

Thanks for the clarification! I had looked at the page @jody references, and it does not mention anything about needing an internet connection. Probably it should explain this.


#10

Thanks, I’ve updated the article with a note to be sure that isn’t missed by others.


#11

There are a few problems I have found with generate report:

  1. When generating a HTML file form SketchUp 2016 the TOTAL row is not working. It would be nice to have such a row in the cvs file as well
  2. The object volume is still in inches, even when the units have been changed to cm
  3. How can you turn off unit format?
  4. If I have multiple copies of a component with various dimensions, they are all mashed together under one definition name. I’d like an option to separate them,

#12

@Speaker

Unfortunately we only format volume in cubic inches for now. This will change in the future.

If I have multiple copies of a component with various dimensions, they are all mashed together under one definition name.

Please use “Create New Report” instead of using the built-in “Component Quantities” report. The quantities report is designed specifically to group items by definition.


#13

Hi All

The problem was my version of IE. For sketchup 2016 generate report to work properly you need IE 9 or higher.
I upgraded to IE 11 and now the report feature works fine.


#14

Dumb Question: WHere is the “generate report” button?


#15

It’s a File menu item.


#16

Thanks. There is no way to tell that from the help.


#17

Cubic meter soon, please


#18

I’d also love to see the cubic meter soon AND also without the word ‘cubic meter’ written behind it in the same cell so I can directly use the data in my spreadsheet.


#19

If you’re on a Mac, cmd-shift-? or go to the help menu, type “Generate Report” and as soon as it pops up (on mine, I only have to type Gen) hit enter. For me, it’s faster that way than to hunt exact menu locations to open.

I don’t know if Windows has such a thing? Buelhler?


#20

@Matthijs You can do something like =value(left([cell], find(" ", [cell]]))) to extract the number from a cell that is formatted like 100 cubic inches.