Sketchup Paint Bucket Not Working


#1

I’ve had Sketchup 8 Pro and have just downloaded Sketchup 2016. I am no longer able to use Paint Bucket in either. I’ve reset the workspace, made sure Face Style is “Shaded with Textures” and I am not trying to paint a component. Clicking with Paint cursor does nothing. I’ve also tried with the “hardware acceleration” turned off with the same results.

I am using Windows 7 64bit with AMD Radeon HD 6450 graphics.

What should I do? Any suggestions would be greatly appreciated.

TIA,

–Martin


#2

You should post an example model, with a screenshot of the face showing as unpainted, and tell us what the material is (name, etc.)


#3

paint_bucket.skp (98.5 KB)

No matter what material I choose nothing happens. However, I’ve noticed if I use any existing InModel colors I can paint surfaces with those with no problems.

Hope this helps.

–Martin


#4

Its working perfect without error


#5

I can change and add materials as I desire in the model that you have created.

My immediate feeling was that you might have set the styles to “shaded” mode, but it wasn’t.

A clue however.

The image there is quite strange.

He has selected one of the tile texture “Dark Gray” one, but the current selection of the material on the editor shows the “default” texture.

Your current selection of the texture should be visible on the big square on the top left of the Materials dialogue for you to apply onto the face.


#6

Try switching off Hardware acceleration in:
Window > Preferences > OpenGL

Restart SketchUp, then try again.

If you see a difference, then try to update the driver for your AMD Radeon HD 6450 graphics card.


#7

Like I said in my initial post I’ve tried that to no avail. Tried updating the driver - have the latest driver. Any other ideas as to what could be causing this?


#8

As I have said, I can paint with the existing InModel colors. I cannot do it with anything in the Materials, nor can I can add any into the Model.


#9

Nope, it is not in shaded mode but in “shaded with texture”.

Interestingly, if I paint a surface with one of those InModel colors and then try to paint with any Material, that eliminates the the previous color.


#10

I have insert new model in ur file and also imported image and with pick color i have given color shade also no problem with the file


#11

I don’t think there is a problem with the file.


#12

When you change materials in the window; does the current material stay as the Default? Like in your screenshot.


#13

I know there is no problem with the file. All files I create have the same problem. Thanks. --Martin


#14

Yeah, sorry that was supposed to be a reply to @atek to save them some testing.


#15

Wade, the answer is no. It does not even make into default! When I click on any material, it does not change anything in the default box. --Martin


#16

Sorry.

Your profile did not say whether you installed the 32bit or 64bit edition of SketchUp. Some of the Intel and AMD 64bit graphics drivers have problems with OpenGL.

Many users must uninstall the 64-bit and reinstall the 32-bit as a workaround.


Now, I also find it strange that you indicate that SU8 worked fine until you installed SU2016. This may point at some updating of a 3rd-party graphics library which has gone awry. (But it seems strange that SketchUp has no problem displaying the material texture thumbnails.)

Anyway, you might try to rerun the installer (via right-click “Run as administrator”) and choose Repair.


As Wade says, when you click on a material thumbnail in the Material Browser, the “Bucket” panel button at the top should change to show you what the active paint material is. (It should not stay as “Default”.)

Just for kicks, I’d try another “known good” mouse.


#17

Just to make it perfectly clear. I am not saying that SU8 worked until SU2016 was installed. It has been some time since I’ve last used SU8. After I installed SU2016 and ran into this problem, I’ve tried to see if SU8 still worked fine. It is then that I found out that SU8 had the same exact problem.

I will try your suggestions and let you know.

Thanks,

–Martin


#18

The point @Wade made was what I was talking about.

When you select a texture from the picker, you should see it replace the square which is showing default material at the moment.

Maybe @DanRathbun’s method will get you there. He is usually right :smiley:


#19

watch it i can change the color and also imported an object


#20

I’m having a really hard time coming up a response, @atek.