Paint Bucket not working properly

I’m on SketchUp Pro 2022 on a PC. I’m an experienced user. Paint Bucket is not working. My model was imported from Revit to Acad to SU. All surfaces were cleaned up with default paint color. Now I’m trying to apply various materials. Nothing happens. I tried resetting the workspace and that didn’t do anything.

I am using the default Architectural Design Style

Here is the model.

johnson study.skp (2.7 MB)

Can you post the model? Are you painting the imported groups or components? My guess, if Shaded with Textures is your active display style, is that the faces inside are painted with a white material that is not the default one.
Edit: I have no difficulty painting faces in the model you posted.

Odd… I’m not having any difficulty either.

I’m trying to paint the individual faces, not groups or components. Also, when I try to change styles, I receive an error message. I wonder if I have a SU program problem, rather than a model problem. If so, what do I do? Uninstall and reinstall?

Did you install SketchUp 2022 correctly? That requires right clicking on the downloaded installer and choosing Run as administrator. If you didn’t or you don’t know, quit SketchUp, find the installer in your Downloads folder, right click on it, choose Run as administrator and then choose Repair.

What does [menu] Window > Preferences > Files looks like?
Any red folders/warnings?

su files

no

I uninstalled the software and tried reinstalling it. I must be doing something wrong. Here is the InstallShield report.


I don’t know what to do to fix it.

Did you try what I suggested with repairing the installation? I didn’t direct you to uninstall it.

I didn’t understand the instructions. I don’t know what you mean by the download installer.

The installer file you downloaded to be able to install SketchUp. It’s likely still in your Downloads folder. If not, you can download it again from Download All | SketchUp

I had downloaded the file previously, right clicked, and run as administrator. But then nothing happens! Task Manager doesn’t show it running either.

Try restarting your computer, it may help.

Do you have another Windows account?
You might want to try installing from that. ‘User’ is not a common name, it might confuse the installer when trying to get the temp/User Interface.dll
How large is the downloaded installer file?
The installShield.log file indicates it’s running with ‘elevated priveleges’, which should take care of read/write permissions.

I have a laptop computer with the same USER and the same SU installation. The material painting works just fine in that installation. So, it seems logical that the problem lies somewhere in the installation on my desktop. I’ve tried restarting too.

Is Windows up to date?

I just checked and it is.

And how large is the installer file?