Sketchup Paint Bucket Not Working

OK. Finally done with your suggestions.

  1. Ran repair as administrator. - No change.

  2. I’ve removed 64bit version and installed 32 bit. - No change.

  3. Tried a different mouse. - No change.

I suspect there must be something wrong with my computer, but what? Is there a utility I could run that could check integrity of files SU needs and uses? Any help would be appreciated.


Try right-clicking a textured material, and choose “Add to model”.
Then click the “In Model” button (looks like a little house.)
Does it appear as an “In Model” material ?
If so, select it from the “In Model” list. Does it change the current material button or is it still shown as “Default” ?

On Windows, the installer is a MSI package. You’ll find it in

There are numerous command line options for msiexec.exe that can install, check, repair and uninstall.

Open a command shell window, and type:
msiexec /?
… a window will popup with all the listing of all the various parameters.

I’d really suspect the graphics driver. You could check at AMD forums and see if they have any beta drivers posted. And whether other users have similar complaints.

It does not add to the “default”.

I am looking at the rest. Thanks, --Martin

Installed the latest driver from AMD. No difference. --Martin

Just a thought; could you have a modal dialog of some sort that’s coming up off screen? If you are or have been running multiple monitors, for some reason, I’ve had SU dialogs trying to pop up in a previous monitor configuration where the current one leaves them off screen, and it wouldn’t let me continue with certain actions, but would let me do other things.
Try clicking on a material, and when it doesn’t replace the default, hit and then the arrow keys to see if it moves a dialog onto the screen.

I have the same issue that mbassani describes in all respects, with the additional problem that the styles choice window is similarly broken. Trying to chose a style returns “error loading file: …” The path indicated is correct and the folders and files exist. I need not describe the problem I have with the material chooser, because Martin has described it precisely as I experience it. I have used 2015 Pro since Dec. 2014, on Windows 7 and now Windows 10 with no problem until this cropped up within the last 2 weeks or so. I’ve updated and rolled back and updated my graphics card, uninstalled and reinstalled Sketchup including trying the 32-bit version. Nothing changes the issue. I am very interested in whether Martin found a resolution to his problem. This thread seems unresolved, as I interpret it.

I pretty much gave up on Sketchup because of this problem. About a couple of weeks ago I wondered if there could be a problem with malware. I’ve tried Sketchup prior to malware scan and it had the same problems. After Malwarebytes found a few malware instances, I got rid of these and tried Sketchup again and everything works well once again.

I never resolved this except by moving up to the 2017 version which is a totally new install. I guess I should try the malware scan regardless. thanks,Alan

-----Original Message-----