Paint bucket doesn't work


#1

Hi guys.
for some reason, paint bucket doesn’t work on any surface in my model.
I made a new rectangle next to my model to try and paint it and it didn’t work at well.

any ideas?
thanks


#2

What do you have the Face Style set to? It needs to be set to Shaded or Shaded with Textures to show the Paint Bucket doing anything. Look under View>Face Style.


#3

Dave while you’re here and on the same subject: is there an easy way to select all surfaces and change to default material? A crossing or window seems to select everything, but when you change the material, often the back sides of the surfaces remain the same. I don’t know of a solution outside of selecting each individual surface and changing both sides one at a time.


#4

If the back faces are visible, you can access them with the Paint Bucket tool.

Might just be easier to delete the material from the In Model collection.

I think TIG has a tool that can help but I need to look it up.


#5

Select all of the faces.
Entity Info > Material icon > Choose default material.

If the material is applied to a group or component-instance select it and set its material to the default using Entity Info…


#6

My mistake. Do what TIG wrote.

Why are you painting back faces anyway. There’s normally no need to do so.


#7

It was Shaded with texture and didnt work. then i changed to shaded and suddenly i saw the colors.
Can you explain me what is the difference and why did it happen?

Thank you very much and thanks for the quick response.


#8

You should see the colors/materials using Shaded With Textures, too. What graphics card? Your profile is incomplete on that topic.

Look in Preferences>OpenGL. Untick Use Fast Feedback. Does that change anything?


#9

(sorry to hijack the thread, itay. I was typing all this out when you replied. I was hoping your issue was resolved)

Allow me to elaborate:

Say I downloaded a plant from 3D Warehouse and I want to change all the leaves to dark red. I double-click until I see that each individual leaf is colored green. I want to change the material of each leaf to Default so I can escape out and change all the leaf colors at the same time.

I select all the leaves with a crossing or window.

I click on Entity Info > Material Info

I choose Default.

Rotating up, I see the bottom surfaces have not changed. But on the right, I still see the Default icon in the Entity Info.

But when I individually select one surface, it shows both sides of the surface in the Entity Info box.

Is there a way to actually select all surfaces when selecting everything and trying to change the color?


#10

With a complete explanation it is much easier to make a recommendation. Try using ThomThom’s MaterialTools to remove the materials. Or as I suggested earlier, you could just delete the material from the In Model collection. SketchUp will replace the material with the default material.


#11

Understood.

If I wanted to keep this material on other entities, however, I would need to do it the old way?


#12

Did you try ThomThom’s Material Tools? It’s Remove from Selection works for me. You could also use his Material Replacer. Both are available in the Extension Warehouse.


#13

Ah, okay. Excellent! This has perplexed me for years!


#14

Its working in both cases now.
Thank you!

but what does it mean? so ill know for next time


#15

Itay, I believe the paint bucket was working, you just couldn’t see it because your face style wasn’t displaying colors or materials. I always keep “Shaded with Textures” selected.