Sketchup not working with integrated graphics


#1

I’ve recently bought the Microsoft Surface Book 2 (15 inch, I7-8650U, 16gb ram, Intel UHD Graphics 620 and GTX 1060 6GB dedicated graphics card)
I’m loving the laptop so far, but I’ve run into somewhat of a problem.

I’m an interior design student and would like to use Sketchup Pro 2018 in the tablet mode to present my work.
In this mode you disconnect the screen portion which makes use of the integrated intel UHD graphics 620 from the keyboard which houses the dedicated grapics.

Sketchup start up fine, however I’m unable to open or display a model, the actual workspace just remains grey. Even the default empty template doesn’t show up, just a gray workspace.
I’m not expecting to be able to do actual modeling in this tablet mode, but I wish to use it a tool display the model, rotate it and such.

If I run the app with the keyboard portion attached but select to use the integrated graphics card, the same problem arises. Suggesting an issue with sketchup’s compatibility with the integrated graphics card. All drivers are up to date, and I have tried reinstalling the app and the drivers.

Is there any way to fix this issue?


#2

Open SketchUp when in the tablet mode, go to Window>Preferences>OpenGL and untick the box for Use Fast Feedback. Does that make a difference?

Integrate Intel graphics cards are well known to be lacking in adequate OpenGL support and are not recommended. See this: Videocard Requirements for SketchUp Pro 2017, 2018, and BEYOND


#3

This has indeed solved the issue.
Thank you so much for the quick response!


#4

You can add your infos here…