Sketchup not working on iPad

I’m using sketch up pro on my iMac and would like to use the program on my iPad too for going on site and convenience!
I Downloaded the app on the iPad with no issues but that’s as far as I got, I’ve contacted the support team regarding the issue and done what they told me but no luck?! It just seems as if its frozen and wont allow me to sign in!??
Would like some help/guidance to solve this problem?!!

I see that you have a Pro subscription under the email address you use in the forum. How old is the iPad that you are trying?

Similar problem. Have been able to use SU Pro on iPad but periodically have to sign in. The problem is no keyboard option when you try to enter your email for starters. Tried to sign in using Apple and Google but that created a username and took me right back to the basics of getting started and asking if I want to upgrade. I cannot therefore open saved drawings. Having paid the tariff decided upon by Trimble, I cannot currently work on the iPad. Brilliant. So now, instead of working, I’m hunting around trying to sort out this problem and face having to take my MacBook on the train to work on rather than the iPad. I thought the subscription service was supposed to be the twitchers? You pay for a service, you expect the full ticket. Working on brand new iPad Pro and new MacBook.
PS: has the glitch with scaling in Layout for Macs been sorted yet?

You might try this:
Be sure to close the app (swipe away)

Download Chrome (if you haven’t got it) and head for and sign in, there.
Try opening SketchUp.


The iPad Pro is an 2017 model A1980


Is iPad up to date with software?

Have you performed a forced restart?

Those are the first things to do/check

Thanks for the prompt reply. Yes, I did close the SU app on a number of occasions for that reason. Didn’t work.
I don’t mean to appear rude but I would expect the app to work as advertised pre-sale and not have to change to a browser I’ve never used for a reason. It doesn’t sound very professional or robust.

Again though, thanks for the reply.

Just an idea to try, a lot of variables going on….
Screen recordings or shots might help in figuering out

One thing that makes me nervous is this line. You can only sign in with one, Apple OR Google: the account you signed in with. Can you message me that account and I can look it up. To confirm, sign in to and confirm you’re seeing the models you expect.


Yes all the above I’ve done/completed, deleted App and downloaded it again still having the same issue.?!


Hi Mike,

I’ve sent some pictures hope it gives you a better understanding


What happens if you click at the bottom right?

It will navigate to Trimble identity!! Can not go any further!?

Hi @brendanogorman22, I am very sorry to hear that the issue is not resolving. I have a few more suggestions.

. What browser are you using to log in? Is the browser updated to the latest version?
. Please, check Firewall and Disable Ad blockers
. If you have VPN, please disable it and see if that helps
. Use a different network, like tethering with your phone if you are currently using Wi-Fi or viceversa

Please, let us know if any of the steps above helped or if the issue persists. Thanks for your patience and collaboration!

This usually happens to people behind very restrictive firewalls or who are using VPNs.

I just tried to open previous files at work on my MBA only to be told that I had to sign in - again - only I was already signed in. It took several attempts to sign out although I could open some recent files but not others. Said “invalid token error” but eventually signed out even though I was already signed out according to the software only when it did sign out, it just signed back in without my having to sign in my details.


So I finally got it sorted, tried everything… when I was signing in with chrome I noticed it defaulted to safari…! Changed that but still wasn’t logging in so I looked at content blockers and changed the settings!?

Thanks heaps for your help!


Hi @brendanogorman22 ! Glad to hear the issue is resolved and thanks for your detailed explanation of how you sorted it out. :slight_smile:

Hey @Bowesy , do you currently have issues or was it just a temporary glitch? We always suggest to clear cache and cookies and try incognito as first troubleshooting steps. I hope you are fully up and running now!

No luck. Still unable to sign in - no keyboard option when trying to sign in