Unable to sign in on iPad app

I am unable to get past the “the legal stuff” section. Continue doesn’t work. I’ve deleted the app and reinstalled it. Doesn’t change anything.

I am also having this problem. 12.9” M1 iPad Pro.
Reinstalled. Restarted. Have followed the links to EULA and privacy. I can log into the website. It’s not my firewall.
Help? Anyone?

I haven’t seen that problem, and it’s late on a Saturday evening, my colleagues may not see your post right away.

@MikeTadros @Barry

I wonder if perhaps rotating the screen to portrait and trying to press the button again might help?

I wondered about that, but thought it won’t work and didn’t suggest it. I would be quite happy to be wrong, though of course it would still leave us with something to fix.

Yeah, I tried that too. Still no luck.

Thanks for trying, and sorry for the trouble here.
If I could I ask you to try one more thing: Uncheck the optional checkbox for receiving emails and keep the checkbox checked for agreeing to the terms. & Let’s see if maybe that works?

Not a problem Mike. That was the second thing I tried. I also tried going to the privacy statement. Selecting the safari logo and signing in on the browser ( Sketchup didn’t know where to send me once I signed in). Thanks for helping me work through this.

Do you have any kind of ad blocker on your iPad?

I have tried portrait and landscape mode, turned off ‘block popups’, disabled ad blockers, disabled private relay and turned off limit ip address tracking, and I even signed up for a 30 day trial, still no dice. On the EULA and privacy pages I have scrolled all the way down and accepted cookies. The ‘continue’ button appears to activate when clicked (it changes color) but the app simply doesn’t do anything beyond that. At first I tried to Sign In with Apple and got this behavior so I created an account on Trimble and have been trying to sign in using that.

My iPad works just fine. My wife’s comes up with the same problem. Tried all the above.

Fwiw I was able to successfully sign in through the app on my iPhone 13 mini. Both are running iOS 15.4.1

Solved!!!
In settings > accessibility > keyboards > turn off full keyboard access.
This worked for me.
You can turn it back on after getting past the legal screen

Somewhere in Denver there’s a software engineer scratching his head… :grin:
Thanks for the help!

The Continue button works for me even with full keyboard access turned on. I’m not sure why a keyboard setting would stop you from touching a button.

Maybe it’s a combination of things. It isn’t stopping me from pressing the button, the button acknowledges the input it’s just the app doesn’t continue

Thank You! I double checked my iPad which didn’t have an issue and it was was attached to an external keyboard and the full keyboard was off. My wife didn’t have an external keyboard attached. Cheers!

Thanks, that helped.

@Barry steps to reproduce:

  1. Sign out.
  2. Delete the app.
  3. Install the app.
  4. Detach iPad from any keyboard.
  5. Turn on Accessibility, Full keyboard access.
  6. Open the app and sign in.
  7. Tap the agree to conditions text.
  8. Tap the continue button.

A minor annoyance is that you can’t tap the checkbox itself.

Mine did not have the external keyboard attached but the setting was on because I sometimes use a keyboard. Maybe that’s the condition that shows the bug - setting on without keyboard attached (as opposed to setting on with keyboard attached.

FWIW the app responding wasn’t random, and for context, I have a Mac IT background. Since it worked on the phone, I compared each setting one by one between the iPhone and iPad. If an iPad setting differed, I quit the app before changing the setting and then restarted the app after each change, one at a time. When a change didn’t work I again quit the app, toggled the setting back and retried the app. As soon as I toggled that setting off the app came to life. I’m confident I could recreate it if desired for a bug report but I don’t have the time or energy ATM. Trimble support, feel free to reach out if needed

I was going to mention that. It caused enough frustration that I began tapping around the screen in futility thinking the app was unresponsive until I happened to land on the text.