Cannot get my iPad to sign in. I purchased the app and it wont let me do anything

I did the free trial. Then I got a new iPad Pro and installed the app on it. Now when I try and start a project, it asks me if I want to purchase the software. When I click on it it says I have already purchased it. I just don’t know what is going on.

I have the same problem

@brxrs8tddz and @Brasso thanks for reporting the issue you’re having accessing the app. Apologies – that’s certainly not the level of experience we’re aiming for.

I’ll get a ticket filed on our end to investigate.

I’m also curious to learn more about the way that you’ve got your device/app/accounts configured.

  1. Are you signed in to both your old device and the new device (and the Apple App Store) with the same Apple ID?
  2. Are you trying to sign in to SketchUp using the same Trimble Account (same sign in option, same email address, etc) on both the old and new devices?

@MikeTadros I am having the same issue it might seem - my subscription through my Apple ID not getting picked up as before.

Just to update as my other post has been deleted. I get the same for iPad as I do for my MacBook Pro’s Safari when signing in with Apple ID - says it’s a free account. Ok not sure it’s solely an iPad issue but more an issue with not getting the subscription from Apple.

Check the (general) iPad Settings > Apple ID > iCloud > Hide email addresses to see the sites/apps use which private_relay address.

The email is hidden for Trimble, which it always has been. This shouldn’t prevent the subscription being seen against my Apple ID though. Other subscriptions are fine with it :thinking:

If you took the 7 day trial on your iPad, that would have been handled by Apple, and they would know your Apple ID email address. If you sign into Trimble with Apple, and with the email hidden, you are then seen as a different person.

If I knew your Apple ID email I should be able to look up whether it’s the one with the Go subscription.

The hidden email is, hence the mad username.

Not sure if I did the trial or not. But bought the subscription with the email hidden.

If you bought the subscription directly on a Trimble web site, with Sign In with Apple, then I’m not sure why it wouldn’t be working.

If you go into Settings, Apple ID, Password & Security, Apps Using Apple ID, see if there is only one Trimble entry, and no SketchUp entries.

Nothing for SketchUp, only “App ID for Trimble Identity”.

Same problem. Periodically have to sign in on both MacBook and iPad. Trying to get on iPad now, only where it asks you to enter your email address, when you tap on it, it does not produce the keyboard so you cannot enter a thing. Tried to sign in using Google and Apple, only it seems to create a new user So does not allow me to open up saved drawings. Added to this, the glitch when trying to scale draw in Layout when you have to tap on a scale above the scale you actually want which then sometimes gives you the scale you actually want. The subscription service is working a treat

Hey ! I purchased SketchUp go subscription on I pad. But the upgrade is not showing in the app. It’s still asking me to purchase. Please help me. I’m not at all tech savvy and this is bugging me big time. Please help someone……

Same issue for me

I can’t access my account it says I have to purchase it but I already did and all my sketches are gone and once I put make new it takes me to the purchase once I click it it says I already purchase idk what to do I have a lot of work to get done with it.I am lost I need help

I can only see that you tried the iPad app at the end of January, but cancelled the subscription so that it didn’t continue after the 7 days. Did you go on to buy a SketchUp subscription some other way?

If you sign into the web app with the same email address you used before, you should be able to go to Trimble Connect and see the models you had been working on with the iPad:

Yes I bought it few days later and have been on it for a few weeks now. I end up doing another 5 projects with it. And I logged opened the app the day after and it logged me out so I logged back in and I could see my other projects but I couldn’t edit them or anything else.

Also all my projects I did are no longer there and I can’t add a new project it tell me to upgrade to another version but I already purchase it. And when I add upgrade it tells me I already have a subscription and it’s not so until March or 2024 so I do t know what to do

I have this exact same issue :upside_down_face: