SketchUp Not Using Nvidia GPU

For the past 3 weeks or so, I’ve encountered a LOT of issues between the latest Nvidia drivers and Photoshop (stick with me here…): some combination of the latest Nvidia drivers and the latest Photoshop updates have caused Blue Screens of Death, constantly. This forced me to attempt an extreme solution: DISABLING my integrated GPU.

This stabilized Photoshop, but then I went to open SketchUp Pro 2022, and I got the dreaded message box that said SketchUp can’t run without a GPU that supports hardware acceleration.

But here’s the thing: I disabled my integrated GPU (per the Photoshop issue), and forced SketchUp to use my Nvidia Quadro driver (the only GPU now available!). I did this in the Nvidia settings:

Only when I RE-enabled my integrated GPU would SketchUp open.

So here’s my question: When I disable my integrated GPU, and force SketchUp to use my Nvidia Quadro drivers, why is SketchUp NOT seeing hardware acceleration?!? It’s as though it’s still using my integrated GPU, even though I’ve specified to use the Nvidia GPU.

I have the latest Nvidia drivers. I just can’t get SketchUp to open when those are the ONLY drivers my computer is using.

Thoughts? Suggestions?

Dave Coop.

turn hardware acceleration off?

Sorry, not sure I understand. SketchUp is telling me that it can’t open because it can’t run without a GPU that supports hardware acceleration…which my Nvidia GPU clearly does…even though I’ve told Windows to only use the Nvidia GPU to run SketchUp.

I’m not sure what you are suggesting (or maybe asking)…

sorry was thinking of something else, got it wrong, thinking of openGL settings rather than doing… hard to solve without the problem in front of me,

Are you using a laptop with an external monitor connected through a dock? Some models, idiotically, use only integrated graphics for external monitors. Updating a lot of drivers and firmware might help.
If you are no longer with Windows 7 please update your profile to show what your configuration actually is like.

1 Like

Sorry about that. Just updated my profile with details of my setup.

Interesting suggestion, because yes…I’m using an external monitor through a dock. Didn’t think about this.

Are you suggesting that the external monitor is still being driven by my internal GPU? And unhooking that might force SU to run using only my Nvidia GPU?

I’ll have to try that and see if it works. It doesn’t make a ton of sense, though, if I’ve DISABLED my Internal GPU, and it’s somehow still driving the external monitor?!?

Thoughts? Suggestions?

Old DisplayLink docks (Lenovo and some others) refused to run OpenGL. Thunderbolt seems to work better but it too has its quirks.

You can test further by

  • attaching your external monitor directly to a HDMI or DisplayPort on your computer
  • trying if Sketchup runs on your laptop monitor

You could also try

  • updating your display drivers directly from Nvidia and Intel (regardless if you use the latter or not)
  • updating the dock software (Thunderbolt or other), network driver etc.
  • there might be computer and dock firmware to update

The internal GPU handles the display controller that connects your display to your laptop monitor.
Your nvidia card is routed through that display controller as a render only device - always.

Usually your nvidia card has a direct connection to HDMI or display port on the side of your laptop.

If you are using an external display controller that is inside of a USB adapter, then you are at the mercy of what that display device supports.

There is an article about it here from a manufactuer of docks with some suggestions and workarounds
Applications That Use OpenGL Such As Google Sketchup or Google Earth Do Not Work As Expected When Connected to a DisplayLink-Based Docking Station - Plugable Knowledge Base

You could try looking for another brand of adapter that doesn’t use a displaylink chipset - maybe that would work better.
Something based on the Parade - PS176 chipset for example.

^I don’t know if this does work.

Good lord, this is bonkers. How can docks NOT utilize the display adapters IN the computer, and rely on something else, when you plug in an external monitor?!? Why would that EVER be a good idea?!?

Regardless, I have worked with Adobe customer tech support, and seem to have a solution to the Photoshop blue screen issues…by reverting to an earlier version of Photoshop. This means that I’m able to enable my internal GPU again, which means that SketchUp is now able to open.

I’m still not entirely convinced the SU wasn’t trying to use my internal GPU instead of my Nvidia card. I guess I can test it by unplugging everything from my dock, disabling the internal GPU, and then seeing if SketchUp will open.

I’ll post results after I attempt that.

Thanks, all. This has been (mostly) helpful.
Dave.

Couldn’t you re-use the driver(s) from where you were a few weeks ago, when things were working ok?
The latest drivers aren’t always the best until all issues are ironed out.

2 Likes