Hardware Acceleration - Can't start Sketch-up Nvidia GeForce GTX 1660i

64 GB Ram Core I7 10750, Latest Drivers, 6 GB video card and can’t run sketch-up. I have checked the accelerated graphics options on and off, and made certain sketch-up is using the graphics card in the nvidia set-up. Any help would be appreciated.

Do you get an error message?

image

How exactly? What do your Nvidia control panel 3D application settings look like for SketchUp?

Do you have another display that you can hook up and make the primal?

Or the other way round: Is your computer a laptop, and are you trying to run SketchUp on an external monitor, especially one connected through an USB “dock”?

That was the issue. Unplug the USB Docking station. I’ll mess with the display settings. Than you for the tip.