Sketchup - (not responding)

Can someone please help me figure this out. My project is due Tuesday morning!

My computer has been running my sketchup file super slowly, and now it takes 5 years to do anything. It is a fairly large file, but my friends is the exact same and runs fine. I have purged unused and used cleanup3 and neither of those do anything. there are hundreds of thousands of edges and faces on mine and not on my friends so Im not sure what has happened. And now, my main issue is that I grouped my whole model together to make it simple to rotate, and not that I need to explode it to edit the model, it buffers for ever then says not responding. I have been waiting over 3 hours for it to load, and I have never had that issue. I normally wait maybe 10 minutes. My drivers and windows are up to date. I have it all on high performance. Any help would be nice.

It would help if you share the .skp file so we can take a look at it and try to help you.

I tried to attach it but it says it it too large of a file (188,673 kb) (I don’t think it should be that large). How can I fix that or minimize it?


Post link or personal message link to DaveR, he’s superbly knowledgeable.

1 Like

Don’t fix it. That’s what I want to see. As @Julian_Smith suggested, DropBox, etc.

Thanks Julian.

When you say you grouped it together to rotate, does that mean you have a 188mb file of free, ungrouped edges and faces? If so, that is a huge problem right there.


Gotcha! Ill upload it to my OneDrive, however it may take a little bit

Well I have grouped literally everything and I have saved the file to my laptop and it still says 188 soooo

Grouping the geometry won’t reduce the file size.

@DaveR here ya go! Let me know if you can get into it

Nope. You need make it accessible.

Have you exploded your groups and components? Or have you just ticked the “Show nested components” box in your ModelInfo>Statistics window? That doesn’t add to the polygon count, it just lists everything that is actually there already (a model with no groups or components runs a tad faster than one with many nested components, but the difference is small so this is no reason not to organise your model).

My one drive is with my school so they have a bunch of restrictions set up. Its a whole process. So it gives me option to share with anyone with the link and I have to give them a password as a temporary pass. Maybe this will work. If not, I will try another way to send it.
Password: Ellis13579

Download started. Hang tight.

1 Like

Model Info

I have EVERYTHING in one group because it wouldn’t load when I would do anything without it being grouped. Now it just won’t let it explode. I sent what my statistics are now. I don’t have a screenshot of what it was before I grouped everything but it was almost a million edges and faces were close behind

The edges and faces didn’t go anywhere - they are just inside your groups.

Not in the file you uploaded. There’s a lot of ungrouped geometry.

There’s a lot of entities floating around in the sky that will cause you problems. Hard to see in this screen shot but look at Entity Info. That’s not all of it, either. Get rid of that and you’ll find orbiting and panning goes more quickly.

Turning off textures by using the Monochrome face style will also help to make your model behave better because your graphics card won’t have to work so hard.

Fix the reversed faces. There should be no exposed blue back faces.

You are using tags incorrectly. ALL edges and faces in your model should be created and left untagged. Here I’ve fixed it.
Screenshot - 12_5_2021 , 2_54_53 PM

You said you purged unused stuff but it doesn’t look like it when I run Purge All.
Screenshot - 12_5_2021 , 3_01_03 PM

You have a lot of obese components in your model that could stand to be simplified. The handrails in the bathrooms, for example look like they’ve got two or three tilmes more edges than the need. It would also help to soften the edges so they aren’t exposed. Those rails are just loose geometry. It would also help to reduce file size if you had one rail as a component that you then copied to use elsewhere in the model.

The plants also add a lot of load to your graphics card. At the very least the give the plant components tags and turn off the visibility. that will help to lighten the load on the graphics card.

Clean up the furniture components. Lots of unneeded detail. Liability without benefit.

There’s probably more but I’ll have to do some deeper probing. This isn’t meant as a jab at you but it’s a typical example of a model that has been allowed to get out of control either because you haven’t been taught correctly or you haven’t been practicing clean modeling workflow.


That helps a lot! I am new to sketchup, and we were just kind of made to teach ourselves for this project so I really just know the basics.

I’m not sure how that model and the updated one got mixed up. If I send the updated file, can I get you to try to ungroup it that way I can fix everything you’ve said?

Go ahead and and upload the model. If you’ve grouped all that loose geometry, there’s really not going to be a change.

That seems to be a common thread with students who post here. And invariably, like you, they post after they’ve well and truly got things out of control and their project needs to be turned in withn a few hours. I wish we had an opportunity to get at students before they have a chance to get in so deep.

I noticed a few more issues–things like a sink with a drain which no one will ever see and other excessively detailed components or lackl of components. What did you have available to start from? A floor plan? Or did you just make things up from scratch? My thinking is that the better option might be to start over from the beginning. Make a lean and clean model that works well.

I also noticed 66 Lumion light components. Unfiortunately your model isn’t ready for Lumion so those components are more a hindrance than a help. Most of those components are packed in a really tight area, too.

As a quick example, I’ve redrawn one of the hand rails from your model. Yours has more than 3300 entities. Mine has 2100 and I could reduce that further.

The extra geometry in the rail you used doesn’t improve your model. It just makes more work for your graphics card and you.

1 Like