Sketchup pro not responding

My sketchup pro will load and then any time I try to do anything it pauses and says sketchup not responding I have sketchup pro 2023

@DaveR

Does this happen with a new blank file or just with your current project file?

I just tried on a new blank file and seems to be working fine it’s just my project for some reason

Sounds like it’s probably in need of some cleaning. If you share the SketchUp file we can take a look. If you don’t want to make it public send it to me in a private message and I will see what I can do with it.

its too big of a file to share could i email it to you ?

Upload it to Dropbox or We Transfer and share the link.

okay will do that might take me a while ill respond asap

Ok. If you want to send it privately, click on my name and then ‘Message’.

It doesn’t let me message u privately but I have Dropbox now

I’ll look at it as soon as I can unless someone else gets to it before me.

still doesn’t let me PM you? and okay great thank you!

You may be in the new member probationary period to prevent bots from littering the forum. After a few posts it should allow you to send a PM. Note, however, if the file is >16MB you will still need to share a link to a file sharing site where you put a copy and made it public.

OK. Since you started this thread I’ll respond here with what I see but since you sent the file to me in a private message, I’ll send it back that way.

First, I expect a large part of your issue comes from heavy components you’ve collected.

These components are excessively detailed. Really there should be no reason any of those objects should be that “heavy”. You should be using lower-poly components espcially for smallobjects. There’s no reason that a wine glass should have over nineteen thousand edges unless maybe the model is only about the wine glass. Almost all of the objects in your model could stand to be put on a diet.

Another thing that would help is to edit the style and turn off Profiles. That will reduce the load on your graphics card and will help speed things up.

You should make sure you have faces oriented correctly. There should be no exposed blue back faces. You can see there are plenty in the next screen shot.

I did my usual cleanup. First I fixed incorrect tag usage. It may be that the tagged geometry came with objects you collected from the 3D Warehouse.


Then I purged unused stuff from the file.
Screenshot - 11_15_2023 , 5_11_17 PM
Don’t hoard unused components and materials. If you don’t use them in your model purge them and make them go away.

Also there are a number of excessively large texture images. Just like with the numbers of edges, there’s no reason that wine bottle labels need to be so large unless your entire story is about those labels.

I made them more reasonable in size. All this cleanup reduced the file size by more than 63%.
Screenshot - 11_15_2023 , 5_12_48 PM

There’s a bunch of stuff hanging out around the outside of your building. If you don’t need it, get rid of it. It’s adding further bloat to your model and makes your computer work harder.

1 Like

Honestly Dave thank you so much, I really appreciate it, I’m quite new at this and so it just confused me and was stressing me out but thank you ! :slight_smile:

You’re quite welcome.