How to fix Sketchup not responding in Sketchup 2016

hi everyone,
I just used sketchup and today I found a problem about ‘sketchup not responding’

Every file that I open always causes problems not responding, my project size is 50 Mb, and I use a Laptop 4 GB RAM and 2 GB VGA with AMD A9 7th Gen.

I have read a lot of ways to improve sketchup not responding on many websites but it hasn’t worked. Do you have a solution?

#I am using Sketchup pro 2016

The ‘Not responding’ message indicates that SketchUp is working trying to do something. One bottleneck might be your graphics card. You could try updating the drivers directly from the manufacturer or the card and see if that helps. Does it work with smaller files?

Maybe there’s a problem with the model itself. If you upload it to Drop Box and share the link, someone could take a look and see.

Okay, thanks dav, are there any other solutions? I tried to do light handling like purge material, but it didn’t help

Did you try updating your graphics drivers?

If you were able to purge materials, did you also try purging unused components?

Again, without seeing your model, it’s difficult to give you more.

I am curious how these 50MB model files were created originally? What version of SketchUp were you using, and did the apparent performance problems that you are experiencing now happen back then? If not, what is different now? For example, have any “big” extensions been installed recently?

4GB of memory in the computer is not very much when it comes to handling a 50MB model (assuming that the model is mostly geometry, as opposed to a few large image files). Was that same laptop used to create the models? If you can, I suggest exiting out of as many other applications as possible when running SketchUp with a large model.

1 Like

even with the fastest CPU you won’t get real-time modeling, better adhere to the good habits of performance optimized modeling techniques in SketchUp:

• SketchUp Help Center: Improving Performance

in short:

  • use component instances for repetitive objects
  • switch of eye candy (fog, shadow, x-ray etc.) during modeling
  • use a fast stile (see icon) during modeling
  • hide stuff currently not needed
  • close the outliner tab
  • don’t be far away from the model room origin which may happen unnoticedly especially during a DXF/DWG import w/ import option “Preserve Drawing Origin” enabled
  • purge model from time to time to get rid of unused resources (“Window > Model Info > Statistics > Entire Model > Purge Unused”)
  • reducing the Anti-Aliasing in “Window > Preferences > OpenGL” to “2x” might help in connection with sub-par, integrated graphics adapters (e.g. intel HD)

To add:
Don’t import 3D entourage elements from the 3D Warehouse (cars, trees, people) without inspecting them first. A single 3D tree may have millions of polygons, enough to kill any model on any computer.