Sketchup keep not responding when open certain files

i use sketchup 2023 pro and my pc is geforce rtx 4080 proart 16gb graphics card with intel core i9 14900K, however i still keep getting not responding notice when i try to move certain objects and suddenly freeze for a few minutes, but when i try to open it on my laptop (intel core I7 10th gen and geforce gtx 10750H) and still can move the objects although its a bit laggy but at least it doesnt freeze at all, any suggestions?

share a file that freezes. if it’s too big for the forum, use wetransfer or dropbox (or similar)

also, what’s the RAM of your second machine, and what’s the speed of both the i7 and i9?
sketchup needs 2 things, RAM, and RAM. oh also, a fast single core CPU.

So, in theory, a 3,2 GHz i7 with 32Gb RAM and a rtx 3050 would handle big complex file better than a 2,7GHz i9 with 16Gb RAM and a rtx 4090
You gave more infos about your i9 than your i7, but considering one freezes and the other just lags, it could be what’s happening here.

Sharing a file would allow other people check on various machines how it’s going :wink:

here you go i cannot move the chandelier component and thats the problem here, also my laptop got 2,6ghz and my pc got 3,2ghz, i will share the spec here

and this is my pc spec

Sounds like an overweight file, bloated with unnecessarily detailed pieces from the warehouse.

I would think of the same thing too, but i think theres something wrong how is that my laptop would run better than my pc? if i tried on my laptop and the file is crash i would think theres something wrong with the file
can anyone fix it?

The group floating above the model is killing your graphics card. Too much geometry for it to handle smoothly.

I did my usual cleanup first. Fixed incorrect tag usage.
Screenshot - 4_18_2024 , 8_13_19 AM
Purging unused didn’t eliminate as much as I expected, especially for as long as it took.
Screenshot - 4_18_2024 , 8_20_22 AM

I deleted that huge group and purged again.
Screenshot - 4_18_2024 , 8_22_21 AM

There are a bunch of obscenely huge texture images that also slow down your graphics card.

The cleanup I did reduced the file size by more than 70% and improved the model’s performance. You could reduce some of the object nesting complexity which would not only help performance but also make your model easier to work with.

do you erase the large group floating above? or do you simplify the group?

I just deleted it and purged the unused components and materials that were included in it. It’s floating above the rest of the model not doing anything useful.

the floating object is the chandelier for the room and that is the most important object for this project, is there any way to improve the sketchup performance to be able to run this file with that object? because i can work on it on laptop better than my pc but its still too laggy, i suppose it should work better on my pc than my laptop right?

Simplify the geometry and get rid of stuff that isn’t important. Is the exterior of this place important?

You could replace things like the paving blocks outside the front doors with a reasonably sized texture instead of individually draw blocks. Look for other places where that can be done, too.

the exterior isnt important, i can erase some of parts that i wont be needed but i cannot get rid anything from chandelier because i need every geometry on it, but does that mean my pc spec still isnt enough to run this kind of complex file?

So eliminate everything that you can from the exterior. As for the chandelier, you could surely simplify all but one of them. You cannot see the detail in all of them at once. Make one the hero component with the detail and make the others simple representations.

It seems as if you’ve invested a lot of time and energy into areas that don’t add value to the story you need to tell. That affects the performance and it means your model is less efficient than it should be.

Your Laptop is much slower, so it makes sense that one is finding it even harder work.

You definitely don’t need those tiny tiny pieces of the chandelier to be there each little pieces is 90,000 entities totalling 7million triangles.

the extreme opposite of this is the wires that are holding those up - which have no geometry and won’t be visible in enscape!

okay but why does my laptop still can operate the file even though its laggy but my pc couldnt even operate this file? is there something wrong with my pc spec or settings?

Sorry to add this after the excellent post of Dave but was faster than me on this one. However, maybe you can find useful information in this post.

I loaded your 259,3 Megs model on my Macbook Pro 2017 without any problem. I even had a 170 Meg model already loaded and the two are cohabiting nicely.

Your model is quite huge with close to 144 millions edges and more than 90 millions faces.

I can orbit, pan and zoom it but it is a little slow.

I copied the fountain to a new file and saving it produced a 13.7 Megs file.

I did the same with the chandelier and the resulting file is more than 129 Megs containing more than 130 millions edges and 84 millions faces.

If these objects come from the 3D Warehouse,I strongly suggest that you import such objects in a new file first instead of directly in you model. This allows you to check for size and also to optimize these before insertion in your main model.

Each of the 12 units making the chandelier saves as a 5.7 Meg file. Each unit contains 196 flower like objects hung from a simple edge. There are 98 white components and 98 orange component. I did a quick check and found that both are the same with the orange components being the same as the white ones but flipped about the component’s blue axis. Using only one component shoul be sufficient. These can then be painted separately as needed. This could save a lot of space when multiplied by 196 then by 12 or 2352 instances in total. Each of these sub units is 5,6 Megs so there is no great gain here.

Also, these flower like curved surfaces as well as the curved edge are quite detailed. These can
also be simplified to reduce the file size even further. Just show hidden geometry and you will understand what I mean.

Learn to create the proper objects for SketchUp, i.e. low-poly models, which you can easily control and adapt to your needs.

Your leaf - 45499 entities
Proper low-poly - 468 entities


its fixed! i simplify every leaves with skimp as much as it can and now it works perfect

thank you all! :slight_smile: