Sketchup Freezing/Not responding when selecting all objects/entities

I was hoping if someone could help me resolve this. I recently purchased a Lenovo Legion 5 with good specs for architecture school. Been playing around, trying to re-create an old site model on sketchup pro 2023 which I’ve recently installed. Imported some vector building data in and tried to explode 2 groups and then regroup it together under one group.

Now, when I try to select these objects, the file just freezes for 5-10 minutes. Something is clearly wrong because my old 2017 Mac held up with this, but my new Legion with a dedicated graphics card can’t.

Is there something I should check on sketchup? My file size is only 30mb. If anyone has any advice or further questions for them to use to help, I’d be much appreciated.

Let me know

Laptop Specs:

Device name LAPTOP-N2EG61JL
Processor 12th Gen Intel(R) Core™ i7-12700H 2.30 GHz
Installed RAM 16.0 GB (15.8 GB usable)
Device ID D4B70A29-DDE0-4D46-9395-D7E507098F53
Product ID 00342-20991-36771-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display



Are you using SketchUp for Schools, which is web based, or SketchUp Pro? Your forum profile is confusing.

How large is the SketchUp file as in how many edges and faces are you trying to select?

as Dave, currently writing, will probably tell you, (edit : oh no, he asked different questions. nice, no repeating then :slight_smile: )

  • check with the NVIDIA parameters that your 3070 card is actually the one applied to sketchup. by default, windows tends to optimise battery life, and not performance.

  • please share the file so we can poke in it. otherwise it’s mostly speculation.

Thing is, size in mb don’t tell us much. I could make you a simple cube with a 30mb png texture.
Or, I could make a texture-free model filled with component (they take less space) containing millions of lines.

The first would be heavy (for a cube) but simple to manipulate. the second would be a nightmare to select, explode and work with. same weight though.


Thank you for your quick response.

How would I check the NVIDIA Parameters? Is this found on the control panel? How can I change this

I’ve tried uploading the file here to share, but this website says it’s bigger than 16mb so it wont allow me. Is there any way you’d like me to compress so I can share?

Thanks :slight_smile:

Upload the file to DropBox and share the link.

Hi, I’m using pro.

Here is a screenshot showing the information you are asking for.



your file is physically huge. it starts about 3km from the origin and ends about 15km (in diagonal)

I purged, cleaned the tags, it dropped almost half the size, but the selection is still super laggy. Less than before though. I moved the whole project more or less centred on the origin.

My guess is, when you imported the DWG, you ticked the “preserve drawing origin” choice. SU has some trouble with extreme distances, either super small or high. 15km is kinda high.

edit :
oh yeah, did a bit of cleanup on top of that. SInce many flat face were in fact triangulated for nothing.


file feels faster now. select all takes about a second, due to the (still) high number of lines and faces.
Capture d’écran 2023-09-15 à 17.07.49

extensions used : Cleanup3 for all the coplanar faces, and Default tag geometry. I also checked material resizer, but this was fine, only colors. And off course, the “model info” panel to purge all.