Objects won't move or not responding

The objects don’t move as soon as normal

All files or one in peculiar?
What version of SketchUp?

Please tell us more.

  • What version of SketchUp are you running? 2021 or something older?
  • What are the specs of your computer? What CPU type and speed, how much RAM, what graphics adapter make and model (4096mb just tells how much memory, but without knowing the adapter type, this might be shared with the system RAM).
  • How complex is this model (look at Model Info window, statistics panel) and also at file size?
  • When this happens, what does the Task Manager say about CPU usage and Memory usage?

Dear Sir,

Thanks for reply. I am using 2021. The other files with models containing a lot more MB responds fine on the same computer with same specs. So its not a problems of any computer issues or speed. For example several other files have about 40, 000 MB and respond instantly to the “move tool” and all the other menu tools fine. But the file with only 16, 000 MB on the same computer is lagging and takes almost 20 seconds. There can be several changes without showing up in the model. I just started this new file, and will probably find out what wrong soon as I haven’t trouble checked it enough. I also reopened another file (copy) with the same model to see if it would fix the problem, and didn’t so far.

Jeff

It is not the file size, but the amount of edges and faces that SketchUp has to process, including what is inside components and groups. See Window menu>Model Info>Statistics, tick the “Show nested components” box. I can make a 1 MB SketchUp model that will bog down any system.

What is there to find in "Window menu>Model Info>Statistics, tick the “Show nested components” box to show whats causing the lag?
I was able to correct the problem in the model. The shadows feature was turned on inadvertently. When it was turned off all the objects moved instantly and responded fine. I wasn’t aware that faces and edges would affect the response time to moving objects in the models or the lag.

It seems you’re right, if the numbers are considered high. In the statistics menu, and showed “Edges” at 2,281,766 and “Faces” at 1,245,177. Is this considered high? I downloaded from 3D warehouse most of the model. But still has only 16k MB while all my other models have at 45K Mb

Aha! Yes, shadows and profiles will both slow down SketchUp because their locations have to be recalculated by the CPU and then passed to the graphics for every motion on the view! On a complex model the difference can be dramatic.

1 Like

Thanks, I usually never used the shadows under the default tray option. But happened to be turned on when starting a new file. There were shadows casted on all my objects based on time of day. Although I might use them later, I prefer to wait until the model is done before using them. But it certainly did speed up the model when turning the shadows off.

Yes, it is rather high, and explains why profiles and shadows cause lags. In a smaller model you wouldn’t notice.

Thanks, This specific model contains mostly structures and furniture from the 3D warehouse as I’m developing my model. But all the other models contain them as well. So it must be the “shadows” and “edges and faces” causing the problems. When I turned off the “Shadows” in the default tray menu, it improved the response time a lot. Again thanks for the help !

1 Like