SketchUp Pro 2023 (Not Responding)

Attempting to open a SketchUp model in Pro 2023 on an Alienware laptop running the following spec - 12th Gen Intel Core i7 2.30 GHz, 64 GB RAM with NVIDIA GeForce RTX 3060 and Intel Iris Xe Graphics. The model size is approximately 60 MB. For some reason SketchUp will not come out of the ‘not responding’ state. Any ideas why this might be.

Usually the Not Responding message is display when SketchUp is doing something and can’t accept any input from you. Basically it’s saying leave me alone, I’m busy.

Share the .skp file so we can see what it might be. Maybe it’s an issue with hardware. A different machine my not have any problems. Maybe it’s some excessively heavy objects or textures. Hard to say without seeing the file.

Thanks for the response DaveR. I can’t really share the model as it’s work sensitive which I know doesn’t help in trying to resolve the issue. If the model is full of complex shapes and items from the warehouse can this effect the performance? I had in mind that if the model was a reasonable file size, i.e. 60 MB isn’t overly large, it would open on most machines? Is that correct?

Yes! This is a common occurrence. Lots of obese components are available from the 3D Warehouse. I regularly see files from users who have added overly detailed entourage.

60 Mb could be a large file. It depends.

You could share the file with me privately if you want other eyes on it. I won’t share it with anyone else.

Certainly. Using components can save file size, but the faces and edges inside them must still be processed by SketchUp. With suitable components it is possible to make a 1-2 Mb file that brings any computer to its knees.
Another thing: Are you storing the file somewhere else than inside your own laptop? Especially, opening a file directly from a cloud service might be very slow.

1 Like


If you have profiles shown, it will have a huge impact on performances with complex shapes. Make sure it’s off (view > edge style or in the styles panel). also check if shadows are off, still in the view menu

Of course that will require getting past the “Not Responding” phase first.

right, what could be done is start a new model and turn profiles and shadows off and file > import the .skp file instead of opening it. It will keep current model settings and ignore the ones set in the problematic model

Hi, I am having issues exporting a 2D to PDF. Currently, there are no textures and only lines.
The file size is 110.1 MB.

I was hoping to import the file to Illustrator to edit a few things on it, as PNG version doesn’t appear as nicely when I am image tracing it.


pdf and eps exports are vector exports. Meaning you only get vector shapes, no photos.
jpg, png, tiff are raster exports, you get the textures but not vector lines you can modify in illustrator.

If you want both, you have two choices.

Either export both a high size png or tiff without lines, AND a simple hidden lines pdf or eps and stack them in illustrator afterward.

Or in Layout, export a, Hybrid view.

a pdf is not a format per say. it’s a box containing stuff. could be images, text, vectors, even 3d. In SU, the exporter creates 100% vector and text pdf.


Thanks for your response. I was able to export it as a PDF file in the end, all it needed was a lot of time!

This topic was automatically closed after 186 days. New replies are no longer allowed.