Problems with opening and working in models of various sizes

sketchup
advice
bug
mac
export

#1

Hi There

If anyone could help ,this would be a life saver !

I am experiencingstrong text** some issues with sketchup models that are sent to me for work purposes** . The models Sent to me are built out using mac book pros on the other users end . Occasionally they use other programmes and export to skp for me .File sizes can range from 150mb - 700mb .

I understand that large file sizes cause lag and may be difficult to work in and that there are a few tips and tricks that can help minimize this and optmise effeciency , Although the Pc that I am using doesnt struggle with that . On a good day I can open up a 500mb file and work in it with minimal lag and on a bad day I cant even open a 150mb Sketchup file without it not responding .

I cannot control how the models , sent to me are built , on many occasions Skp files have very little in them but are extremely large ! what could be the issue with this ?

The problem comes in with being sent 200mb files and barely being able to use the copy and paste option without Sketchup failing to respond . Im not sure if its because these models have been exported form a different Programme e.g Rhino . are there issues with using models that have been exported to skp from other programmes ? whats the best way around this ?

Why is it easy for someone with a mac book pro to open ?where this was exported from a different programme I struggle to even move around in the model ?

My laptop specs :

Acer
Predator G3-572
Notebook Pc
Intel® HD graphics 630
NVIDIA GeForce GTX 1050 Ti


#2

@DaveR has saved many lives, here.
Check if your machine actually uses the Nvidia:
In SketchUp:
Window->Preferences->OpenGL->Graphic Card Details
If not and you are on a laptop, what often happens is that the bios software only let you make use of the internal graphic card instead of the more capable Nvidia, to safe battery.

Rightclick on an empty spot of the desktop and choose the Nvidia control panel. Tab the 3D settings and add SketchUp program to use the Strong Video card at all times, apply changes.

See if that makes a difference.


#3

Thanks For you reply !

I have checked the sketchup setting and it is using the correct graphics card .

  • In the NVIDIA control panel in the first Tab the graphics is on auto select , is that correct ?
  • I have added SketchUP To the stong video card and applied changes .

Opened the model that has given me a great deal of trouble and still major lag , to the point of sketchup not responding .


#4


#5

Its in the programs tab.
Prevent autoselect.
Sometimes you would need to reboot.


#6

I have done everything accordingly and still no difference seen , model continues to not respond and lag at the simplest of movements/commands .


#7

the only mac/PC skp file conflicts I have ever seen were due to text in the files using a ‘mac only’ font…

do the drawings contain labels?

john


#8

Nope the file does not contain any labels ,
does that actually effect the model capacity to function ?


#9

It was a rare event that came up on the SketchUcation forum…

I haven’t heard of the issue since SU version 8, but that is what your profile says your using…

if not fonts then import file type and import settings are the next suspects…

add more details and or a sample file…

john


#10

Have you purged the file?

Window > Model Info > Statistics > Purge Unused


#11

Yes I have purged the file , it makes no difference .


#12

File size is a highly unreliable predictor of model performance.
The way in which the model is displayed onscreen has a tremendous impact upon performance.
That is, the Active Style.

The fastest Style uses Monochrome face style and only Edges.
Turn off Profiles, Endpoints and all the other unnecessary edge rendering effects.


#13

Thank you for that , if the file size is a highly unreliable predictor of model performance what could be the problem ?

I have turned off all of the above and still no difference ,
I then tried each of the following explode/double click the group / copy model / import model into a new file
and still not responsive / keeps loading and any click triggers the file to not respond , even if this is minimized .

side note : in the case of the file not loading >yes great idea to wait > but in most cases I have to meet deadlines and have to close the programme and try something else .


#14

Much depends upon what is in the file and how the model is built.
Sharing one of the problem models would help us help you.
At least, post screenshots of Model Info > Statistics so we have some idea of what’s involved.
Like so…


#15

Also, model file size can be affected by large textures without necessarily involving a lot of geometry.


#16

MODEL%20INFO%201 MODEL%20INFO%202


#17

In my opinion, models with an edge count nearing a million are quite large and complex.

In my experience, the Rhino to SketchUp exporter creates way too many edges and faces out of the Rhino NURBS surfaces even when the polycount slider is set to its lowest. I have got better results (a lower polycount) by first converting the surfaces to meshes in Rhino and using the Rhino polyreducing function with quite low parameters before exporting to SketchUp.


#18

So I have had someone look at my files and Pc to see that everything is running the way that it should and that everything is set correct in settings , in terms of the graphics and pc .

He then had a look at the sketch up models that have been giving me major issues "the models that have been exported from Rhino "

these steps drastically changed the model and made everything work smoothly :slight_smile:

  1. Changing the style to "construction’’
  2. View > deselect edges and profiles
  3. components > purge all unused " doing this had the biggest impact "
    4 . Window >model info > units
    checkeing that the scale was correct . "this only impacted the Rendering programme , so after adjusting that everything was fine in the rendering programme . "
  4. Window >model info > rendering > deselect the "use anti aliased textures " this shouldn’t affect your rendering programmes , but drastically improves the speed on your model . !!

DOES ANYONE KNOW OF an option of somehow purging all the Images you have in the model ? , we tried looking for that ,to optimize speed . purged%20unused


#19

Instead of purging in the Components panel, go to Window>Model Info>Statistics and purge unused there. That will purge unused components and then unused materials.


#20

All with the same file?

You can have a look at the textures with the new plugin from the SketchUp team…