Sketchup new install - won't launch


#1

I’m using a brand new work laptop (H.P.) and struggling to launch the sketchup application. This is a clean install of sketchup Pro 2018, is licensed, running on windows 10 with all updates. I installed from an exe and used “run as administrator”.

I’ve been able to open sketchup files after a PC restart. However:

  • i cant open multiple instances of sketchup. The Welcome launch screen opens, but nothing happens after that. then I unchecked “show tips on startup” and now nothing happens at all when i launch the program.
  • After sketchup starts the first time, and I close it, I can’t open another sketchup file. Nothing happens.

I’ve tried opening existing models and also blank files.

Looking at Windows processes, I see no sketchup programs running but a lot of “Sketchup Application” background processes, and Sketchup Webhelper.exe processes. . Some show 0.1% cpu useage and all show a few megs of RAM used.
(I’m guessing i tried to launch sketchup lots of times, hence the multiple processes).

I should note I’m logged in to an office network remotely. Could sketchup be looking for a file (template or component library?) in a network location it can’t see or doesn’t have authorisation to access?

Before I perform a clean install (takes ages) is there anything I can try?

Cheers
Sam


#2

After a restart, Sketchup won’t launch at all.

I can confirm that each time i launch sketchup another entry appears in the processes window.

Also, the Sketchup Application background task is using network bandwidth (between 2 and 6mbps).

I tried running the Windows program compatibility troubleshooter. Sketchup still won’t launch.


#3

If I’m reading you right and my memory is working, sketchup doesn’t work correctly on a remote desktop because of graphic card opengl issues.


#4

Hi Box, thanks for answering. I don’t know a lot about networking - maybe i used the wrong term (‘remotely’).
To clarify; I’m not accessing or running sketchup through a remote (virutal) desktop, but I am logging on to windows using a company-assigned username and password (user@companyname.com). This (‘direct access’) authorisation grants me access to the shared file system that includes my working files plus sketchup’s template and material & component libraries. Sketchup is installed on this laptop (C:\Program Files\SketchUp…).

All my other software (autodesk, adobe, skype, msoffice, etc) runs fine at both home and office, online or offline. I might be barking up the wrong tree with the network access thing but I cant think of what else to test.

The laptop was running sketchup fine earlier today when I was at the office, but it stopped working when I came home this afternoon. Tomorrow I’ll test it back at the office (and contact Sketchup technical support if i cant sort it).

Sidenote: i hope it’s not the case that sketchup won’t run on a virtual machine, Many companies now staff with lightweight tablet/notebook devices and use VMs for the ‘workstation’ software. “It’s the way of the future”.


#5

Did it work at work with another monitor attached, it could just be hiding off screen.?


#6

Even if you get it to run, it is prohibited by Terms of conditions per 1.1:

https://www.sketchup.com/license/b/sketchup-pro

A StandAlone License is personal i.e. licensed to a registered real person.
This person may activate their license on two (physical) machines.

Off course, ‘the future’ will show us how SketchUp will deal with VM-environments.
Network licenses are prone to be candidate for Virtual environments regarding licensing and activation. With Network licenses, it doesn’t matter who is using SketchUp Pro, but the number of active users.


#7

Good thought - but sadly that didnt fix it. Sketchup seems to be stopping before the program properly launches (it’s not in the list of running windows apps, it’s just listed as a background process, and the icon is not active in windows start bar).


#8

Hmm, I wonder if it is looking for the network license …


#9

Is there any sort of file I can delete that forces me to then re-enter the license code at startup? We have 15 licenses in my team, but theyre not a network license, they’re all just licensed to “IT Staff Member.” Or maybe a “repair installation” option in windows?

LayOut still works (tried launching Sketchup via the layer model interface but it still didnt launch).

I also tried launching windowed, minimised, etc…no luck.

I noticed that there’s a windows service that starts using network bandwidth when i try to run sketchup: Service Host: IP Helper. Not sure if it’s important.


#10

Sorry, all that stuff is outside my box.


#11

Thanks for your time!
I’m going to call it a night and try back in the office tomorrow.

Fresh install might be on the cards.


#12

You should stop wasting time in the forums and contact Technical Support.

I believe they will confirm to you that SketchUp has latency issues accessing files located on network storage. (The forum is full topics where people have failed at directly loading model files from cloud storage or even local network drives.)

So, your first test is copy the templates folder from work and paste it locally on your machine and make sure SketchUp’s template path is set to point at a local file. From the Ruby console:

(I believe I had the not loading error previously in an older version during testing, when the template path was invalid. But we’d hope SketchUp would just generate a basic model with default style. But it has been a long time.)


#13

Okay i’ll contact them…

Today at the office its working fine! Even when i disconnect from the internet/network entirely and reboot. Difficult to diagnose.

The template was actually pointing to a local file (i hadn’t yet mapped it to our company template directory).
So the only things not local are the materials & component libraries - these need to stay as a shared team resource (50gb+).