I cannot get Sketchup to start up? Just installed


I have just downloaded Sketchup and can’t get it to launch at all? I can however launch the Layout and Style Builder apps.

I did a search and read that trying to open it in a few different ways may help… like opening a Layout file then clicking on “open with Sketchup” way work. I didn’t.

I have turned of all the parts of the Windows Defender I can find, didn’t help.
Tried the Troubleshooting app in Windows. It didn’t hepl either.

I am running Windows 10 up to date as of today. Its a fresh install as well.
32gigs of ram, and a Nvidia Quadro p5000 gfx card.

I don’t really have any other applications installed that could interfere, as i just installed the OS.

I have tried an SFC and DSIM in powershell… I’m not exactly sure what they do but it was recommended.

I looked at the Event viewer and it says…
Faulting application name: SketchUp.exe, version: 21.1.332.0, time stamp: 0x00000000
Faulting module name: ucrtbase.dll, version: 10.0.19041.789, time stamp: 0x2bd748bf
Exception code: 0xc0000409
Fault offset: 0x0000000000071208
Faulting process id: 0x204c
Faulting application start time: 0x01d7d0cae6467a66
Faulting application path: C:\Program Files\SketchUp\SketchUp 2021\SketchUp.exe
Faulting module path: C:\Windows\System32\ucrtbase.dll
Report Id: 86791585-adba-44a6-b53b-6ee152497ed9

I have no idea what it means though.


When you installed SketchUp from its exe installer file, did you select its icon and in the right-click context-menu choose “Run as administrator” ?
Do it now and when prompted choose ‘Repair’…
Restart the PC to see what’s what…
It might help …
The file C:\Windows\System32\ucrtbase.dll
Does it exist ?

Try running a powershell [as admin] and type sfc /scannow
That might fix things…

Yes Installed as Admin. as well as ran it as an Admin.

I have tried to use Repair as well.

The file does exist in a few location, It seems to be part of the Visual C++ redistributables.

I’ve tried repairing them as well as reinstalling them.

Yes I have ran powershell commands

“DISM /Online /Cleanup-Image /RestoreHealth”
sfc /scannow

also downloaded all the other C++ Visual Distributables just to see if it was looking for a different year.

I appreciate the recommendations.

So I tried an app called Restoro… it said it found 100,000 issues! it also said it fixed them… I did not fix this.

Do you have Visual Studio? It might have come with another version of that .dll
SketchUp uses Microsoft .NET Framework 4.5.2

No , I always see it in the programs and software section of windows, but I don’t know what it does.

Do not run the SketchUp.exe itself as an admin…
This will only lead to extra issues - like no drag-n-drop !

Obviously something is adrift with your Windows installation rather than SketchUp…

Have you tried [re]installing NET framework 4.5.2 as Mike recommended above ??

no i haven’t, i tried but it said it was already installed and didn’t have an option to repair or reinstall. I’m looking into what it takes now.


I have NET framework 4.8 Advanced Service and NET Framework 3.5.

I do not have 4.5.2

Is that a problem?

If i try and install NET Framework 4.5.2 i get this window.

.NET Framework 4.5.2 or a later update is already installed on this computer.

I would strongly suggest another fresh instaalafter creating a new partition on your drive. This will get rid of everything. Also do not use the types of apps that claim to “FIX” things. They are of no value on a properly running system… Also I have found in the distant past, they do more harm than good.
when you get the OS installed, the next items to install are the chipset dtivers from Intel or AMD then the video drivers. Next install SketchUp and it should work.

Yeah I guess I’m forced to reinstall.

Tried to replace that uctbase.dll with a new one… it resulted in the BSOD!

Thanks for the insight…

How about this ?
Uninstall the NET Framework 4.8
Immediately install NET Framework 4.5.2
Try SketchUp.
Any improvement ?
Try installing NET Framework 4.8 again.
Try SketchUp.
Any improvement ?

Reinstalled Windows 10
Updated Windows 10
Reinstalled my gfx nvidia drivers
Re-downloaded Sketchup
Installed Sketchup

Everything runs great, except Sketchup
Layout works fine.
Style Builder says " You are offline, Check your Internet connection to start using Style Builder"

I’m definitely connected to the internet as I’m typing this… I added an exception allow Sketchup, Style Builder, and Layout through.

Are you on Windows 10?

In the Services I can de-select Net Framework 4.8 which seems to uninstall it.

But I cannot figure out how to install 4.5.2? I download the NET Framework tool, it does its scan, then I download the 4.5.2 installer…

it starts, but then throws up a window that says its already installed or a later version is installed.

I’ll try it again though.

tried uninstalling 4.8, then reinstalling it… no change

on Microsofts website for the NET Frameworks is say 4.8 will work for applications needing 4.0 and higher

this is exhausting

Sketchup, Layout ans Style builder are literally the only things installed at this point

its still that–
Faulting module name: ucrtbase.dll, version: 10.0.19041.789

May I ask what the latest Windows update you have is, I might try and roll it back one…

I vaguely remember seeing the NET Frameworks in the updates when it was installing them all.

I am using 21H1.