SketchUp won't run - Faulting module name: ucrtbase.dll

Recently we’ve seen a rash of issues on Windows 10 stemming from an issue with the ucrtbase.dll. This causes SketchUp to refuse to start, returning an error like this one:

Faulting application name: SketchUp.exe, version: 18.0.16975.0, time stamp: 0x5a04a906
Faulting module name: ucrtbase.dll, version: 10.0.17134.254, time stamp: 0xea85cc89
Exception code: 0xc0000409
Fault offset: 0x000000000006ce88
Faulting process id: 0x3f6c
Faulting application start time: 0x01d44b727b7d1c97
Faulting application path: [C:\Program](file:///C:/Program) Files\SketchUp\SketchUp 2018\SketchUp.exe
Faulting module path: [C:\WINDOWS\System32\ucrtbase.dll](file:///C:/WINDOWS/System32/ucrtbase.dll)
Report Id: 100dd992-8ccb-4bc1-bfea-0274de2eedfd
Faulting package full name:
Faulting package-relative application ID:

The ucrtbase.dll issue is a windows issue, specifically an issue with the Microsoft C Runtime Library. SketchUp needs access to that library to run, but it seems a recent Windows update may have broken their ucrtbase.dll as well as other kernel level objects.

You can run the System File Checker tool to validate these kernel files. Here’s how:
https://support.microsoft.com/en-us/help/4026529/windows-10-using-system-file-checker

The Deployment Image Servicing and Management (DISM.exe) command MAY be a fix but it is only recommended for users who are comfortable toying around behind the Windows 10 curtain.

I just installed 2019 PRO yesterday. ucrtbase.dll is causing an error, I see it in the event manager. Both Layout and Style Builder work. But Sletchup does not launch. Same error every time related to that dll.

Which ucrtbase.dll is it that’s causing the error ?
There are going to be several spread about your PC.
Several apps use their own, but I don’t think SketchUp does that…
You could try a system check and repair if it’s a system dll…

But my guess is that perhaps you didn’t install SketchUp properly ?
To fix that try the following…
Whilst logged into Windows as your usual user-account, ensure SketchUp is closed.
Find the SketchUp installer exe file - probably in your Downloads folder ?
Select the exe file’s icon and right-click > context-menu > “Run as administrator”
When prompted choose “Repair”…
When it completes, restart SketchUp and see if that helped…
Doing a ‘Repair’ like this should impact on any custom setups you have already made - like Extensions…

Running a Windows installer exe file for any complex app in any other way will inevitably cause all kinds of unexpected issues, often involving permissions.
So never double-click an installer’s exe to “Run” it - even if you have admin-powers it is NOT the same as doing it correctly…

1 Like

Description:

Faulting application name: SketchUp.exe, version: 19.0.685.0, time stamp: 0x5c12c5cd

Faulting module name: ucrtbase.dll, version: 10.0.17763.1, time stamp: 0x309241e0

Exception code: 0xc0000409

Fault offset: 0x000000000006db98

Faulting process id: 0x50dc

Faulting application start time: 0x01d4d3395fa8003d

Faulting application path: C:\Program Files\SketchUp\SketchUp 2019\SketchUp.exe

Faulting module path: C:\WINDOWS\System32\ucrtbase.dll

Report Id: 5fee19dc-9fa2-4ac4-b956-f50117d9f225

“Whilst logged into Windows as your usual user-account, ensure SketchUp is closed.”

LOL

Did you read my first reply? It does not even start…It’s not ‘open’. Nothing in Task manager, no backgrounds tasks. Nada.

I installed it as administrator. That is not the issue here. I have tried that ‘repair’ choice many times, that does not work either.

Each time I uninstall then reinstall, I get this warning about a C++ library - Visual C++ “14” Runtime Libraries (x64)

That window as you probably know, only let’s you continue or cancel, with cancel stopping the install. When I continue with the install the next stage of ‘supposedly’ installing the “14” runtimes, happens very, very quickly. Makes me think it is not actually installing anything or, this is some archaic installer that you guys are using?

Since my Win 10 Pro 64 is running 1809, and therefore is running C++ 2017, is this why Sketchup is not starting?

My Win 10 64bit + v2019 works fine with C++2017 installed [it actually reported as 14.15.26706***]
I also have most of the others [in either bitness] back to C++2008, but interestingly NOT C++2011, C++2014 or C++2016
So SketchUp will run without those…

***It seems that this Lib [and several earlier versions] might say ‘2017’ but is a version of ‘14’ ?
The latest C++ lib is downloadable here:
https://aka.ms/vs/15/release/vc_redist.x64.exe
It is 14.16.27027
I have now installed it and after a system restart everything still seems OK with SketchUp…
I am no a amber of the SketchUp team - just a user like you.

I’d advise that you try manually updating the C++2017, then restarting, then reinstalling SketchUp 2019 again…

1 Like

copying (not moving) the “ucrtbase.dll” from the Windows System32 directory to the SketchUp program directory might be worth a try too.

But there is never that ucrtbase.dll in the SketchUp directory - in any current or older versions.

Another possibility: Go to settings>apps and features, locate the C++ entries, left click on each select modify then repair. Follow the prompts and restart as necessary and when finished. GL

of course, putting in the progam directory might lead the concerning application to use this one instead of the version the Windows System32 directory.

I tried both of those, latest 2017 C++…again.

And copying that dll in to the program main folder. No go…2019 does not start. Same error every time.

Tried the modify repair thing too…After 5 restarts…no go…

It doesn’t…

Event viewer error after doing all of those suggestions above.

Faulting application name: SketchUp.exe, version: 19.0.685.0, time stamp: 0x5c12c5cd
Faulting module name: ucrtbase.dll, version: 10.0.17763.1, time stamp: 0x309241e0
Exception code: 0xc0000409
Fault offset: 0x000000000006db98
Faulting process id: 0x5710
Faulting application start time: 0x01d4d36040b3d81a
Faulting application path: C:\Program Files\SketchUp\SketchUp 2019\SketchUp.exe
Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
Report Id: f66ae23e-003d-45b8-b89b-07dcd5e9fe41

As you can see it is still trying to get the dll from system32 folder, just like normal.

So I deduce that you have tried downloading/installing the latest C++2017 [14.16.27027] ?
The version of the C:\WINDOWS\System32\ucrtbase.dll I have is exactly the same as yours !
But mine works but yours doesn’t… weird…
Did you restart Windows after manually installing it ?

If you read my reply that stated…“after 5 restarts” :wink:

I just looked for a new nvidia driver. There is one released just today. I am downloading that, but I really do not think this is a driver issue.

For the record my pc is packing i9 7900X @4ghz - 64 GB DDR4 RAM - and a GTX 1080 ti with 11GB GDDR5

Sketchup is on a M.2 nvme Samsung 970 SSD.

I really do not think I should be having these issues trying to get this program to run.

I have zero issues with any of my Adobe CC 2019 suite, Keyshot 8.2 and Maya and 3DSMax all run like a dream on this rig.

A last resort, reset windows and choose keep my files. If you do this backup all important files and docs as a safety precaution.

Yeah I am not doing that. No one should have to lose all installed programs to get one program to work…And still there is no guarantee that will work anyway.

I am asking for my money back.

Or, if you haven’t already, you could enter a ticket in for support and ask for assistance from the support team directly.

Yeah did that, have waited 18 hours for a reply from Theon…How do I get a refund? I have wasted nearly 2 days on this, it is costing me money trying to get this thing to work. I am done with it.

[quote=“zTeK, post:16, topic:78427”]
No one should have to lose all installed programs
[/quote]When you reset the PC with the keep the files option it also leaves the installed apps in place.

We’re taking a closer look at this now. I believe, in this case, everything was working well with Windows update 1803, but not with 1809. Talking this over with QA now to see if we can get a fix on what’s causing the ucrtbase.dll error.

Edit
To clarify, I believe everything was working will with SketchUp Pro 2018 and update 1803. This could be a red herring, but worth noting.