Sketchup Models 2022 are not displayed in VR

Sorry, the file is too big (max. 16 MB), here is the WETransfer-Link

https://we.tl/t-YzwAiyRrz9

ATi

The model includes some detailed terrain, some contours, and a bunch of buildings. The contours and buildings are way above the terrain. Here is just the buildings, sat on the ground. See if this works in VR.

UmgebungOnGround.skp (241.1 KB)

Sorry, that does not help. For the immersive feeling we need the original model.

image001.jpg

Here are some images from SU to compare:

Umgebung (Original)

UmgebungOnGround

Umgebung (Moved & Saved)

I’m now using the second version supplied (Umgebung1).

I’ve Purged Unused, Saved the model so that it is in the viewport and removed geo-location. I also saw that the units don’t match in some of the fields:

Umgebung Units

That’s been changed to Feet. I also named the unnamed tag, “Topo”, and grouped the three groups into one group, “AllGroups”.

None of this worked. The model is still far from the origin, the CityGML and DGM1 are out of alignment and the scale is off.

Explode all groups in groups… And after much more fiddling (and exploding all groups in CityGML):

… Okay, I finally got this to work…

I can explain how to set up your models for better display… but this took too long so for now - goodnight!

Here is a link to a version of your model to test: Sign in to your account

*** The following may be a bit confusing, so I’ve added a bunch of images to help. The main takeaway is that the axes of your model (Model Origin), and the group ‘bounding boxes’ are out of alignment even though the model looks correct. This alignment problem makes things more difficult to work with in the long run. A solution is to be cognizant of model and component axes from the start and employ tactics in your workflow that make these work for you instead of against you.***

It seems that a main issue that SU Viewer for VR was having is that your groups had different axes. This may have contributed to the CityGML and DGM1 ‘Layers’ (In SU Viewer VR) to display at widely different locations (and scales) in VR space. Here is what your model view looks like when I open it in SU (with CityGML selected):

The above is the model origin with which the CityGML Group is ‘centered on’ (but it is higher than the model origin).

Now look at DGM1. There’s nothing to see because this group is much higher than the model axis.

And a nested group of DGM1. It is as if the higher level of the group is aligned to a center point higher in the model space but the nested group is aligned to the ‘center’ of the model axis (which is ‘bassackwards’ and confusing).

Another thing to notice is that when your file is opened, the models aren’t visible. This is because the bounding boxes of the groups are higher than the model origin (and the model is zoomed-in, putting them out of sight). A reason these things are important is that SU Viewer for VR wants to open your model at the model origin and just like in your SU version of the file where the model is not visible, it’s not visible (or at least not obvious because it is ~200 meters above your head) when the model axis is placed.

This image shows the CityMGL ‘component’ axes and the Model Origin axes (Turn on Show component axes in Model Info → Components). In this case, the ‘component axes’ are the same as the corner of the group’s bounding box (and neither is on the Model Axis).

And this images shows DGM1 and Höhenlinien. The ‘component axes’ are on the Model Origin. The bounding box origins are not on the Model Axis. None of the group bounding boxes are aligned with each other.

This images shows that neither the yellow bounding boxes of your groups or the ‘component axes’ are aligned with each other or to the Model Origin AND the component axis of one or your groups is not in the corner of the bounding box of its’ group (DGM1 and Höhenlinien’s ‘component axes’ are at the Model Origin).

It seems that SU Viewer for VR was putting these bounding box axes on the Model Origin axis and this caused them to be out of alignment with one another.

The solution was to explode the groups and make components of them. Those components were manually aligned and put inside another component which seemed to fix the problem of the groups being displayed far from one another.

Let me know if this helps. I’d be interested in learning about what you did to create this model as it’s not bad (excepting the part about not displaying in SU Viewer for VR).

Hi,

thank´s for your analysis. I know this, but that´s the only GEORef-workflow which works with Sketchup and I cannot not change this, because it generates too many other problems.

The only solultion I see is to adapt Sketchup for VR. My wish is to walk on the DGM in VR.

I am convinced you and the Sketchup team is able to implement this.

Thank´s in advance.

image001.jpg

Were you able to download “UmgebungCopy.skp” from the link? I was able to walk on DMG1.

I downloaded the file, but structure and georeference is gone. That´s not an option. The original skp-file should not be modified!

image001.jpg

I’ve manually re-added the geo-location (waiting to upload/sync).

What do you mean about the “structure” being gone? I did remove the Höhenlinien group. But that could be replaced. There was also an un-named tag on Höhenlinien that I removed.

Also, the nested groups in CityGML appear to be shifted and rotated relative to each other and do not appear to be a logical grouping (they are scattered all around):

CityGML and DGM1 are ‘out of alignment’:

Are those the “structure” issues you are referring to?

DMG1 is ‘heavy’ and causes SU to hang sometimes when I convert it to a component.

If you can convert your groups to components (trial 1) and then create a component out of the components (trial 2), one of those might work. If you create those versions and send them to me I’ll test them.

At the very least try putting your all of your groups into a component (I think I tried this and it didn’t work) - otherwise the model will show DGM1 and CityGML very far from each other (with the exception of some of the buildings) when opened in SU Viewer for VR.

Hi,

you find my answers in red.

I do not understand what you mean. I cannot see your answers. Please re-send.

https://we.tl/t-033NVFrF2C

image001.jpg

FYI
Perhaps you are not aware: You are using the email answer to public forum post. This email will not include the history.
Better to visit the forum and answer/post here.

1 Like

The neu model version opens very far from the origin in SU Viewer for VR. You can see part of the model above the cursor. The other part is a very tiny red looking dot to the left of the cursor. So again, SU Viewer for VR is misinterpreting the placement of ‘model parts’ relative to each other.

I will look at this again later as I have to go out now.

I’m very curious to see what else is new in this version:

The simplest solution is to convert CityGML to a component and explode all groups in Gelände → CityGML. The model will then open correctly in SU Viewer for VR. I further simplified the file by exploding Klingewalder Höhe 2 (I had hoped that a top-level component would keep the other components and groups organized when opened in SU Viewer for VR. But no.).

https://holodesigninstall-my.sharepoint.com/:u:/g/personal/james_northhillhardscape_com/ET1PDpSvbWpNghhOv0oeymEBVCiw5LJMZhdgx9ZEQPnHVQ?e=rFaWir

I tried:

*Creating components out of all Groups in CityGML. This did not work.
*Creating components out of all Groups and SubGroups in CityGML. This did not work.
*Moving all SubComponents out of Components nested in the CityGML Component. This did not work.
*A bunch of other ways trying to preserve the overall structure of the file.

In general Einfügepunkt and Kontrollpunkt would render very far from Gelände → CityGML (as groups or components) in SU Viewer for VR. For whatever reason, nesting resulted in misplacement of Groups and Components relative to each other.

I’m speculating that a main reason for this problem is that Einfügepunkt is on the Z axis location of the Main Model View. The nested groups in Gelände → CityGML → Group → Group (of all SubGroups inside of Groups) are placed relative to the Model View/Einfügepunkt Z axis. But the Z axis of Gelände → CityGML → Group (the Groups in which the SubGroups align to the Z axis of the Main Model/Einfügepunkt) are on the Z axis of Gelände → CityGML.

Verrueckt machen!

Anyway, I haven’t been able to do a good job of explaining what looks like the problem. If you wanted to keep your Groups and SubGroups it seems those would have to have their axes moved.

I guess if the purpose is to only visualize and do a walkthrough in VR of a specific part of the model, you could always select the desired component, Save As a different skp and load that skp in VR.

Aris, are you able to use the file? It works well for me. It just doesn’t respect the ‘structure’ of the nested groups.

To be honest I got rid of everything else except for the terrain and the buildings which I dropped on the terrain and purged everything else (assuming that this is a visualization rather than a model organization exercise). But yes, that worked well.

Btw, if you folks want to stay up to date with the stuff we are working on we have opened an Alpha/Beta testing group for XR if you want to join. Read more here: SketchUp XR - Join our Alpha/Beta Testing Program

1 Like

Sorry, but I cannot see in the VR-App the updated model from James (Umgebung-neu-final.skp). Do you use another VR-Version?

image001.jpg

I am using a recent version SketchUp Viewer for VR (2.5.31). There is a link to SketchUpViewerVR-2-0-0-5.exe from the link provided by Aris earlier in this thread.

I’m also opening SU Viewer for VR from the Oculus Home (see my previous link above about how to make sure that is working).

The model I uploaded, “Umgebung-neu-Final.skp”, should open above your head, like this:

Which devices are you using?