Sketchup Models 2022 are not displayed in VR

The neu model version opens very far from the origin in SU Viewer for VR. You can see part of the model above the cursor. The other part is a very tiny red looking dot to the left of the cursor. So again, SU Viewer for VR is misinterpreting the placement of ‘model parts’ relative to each other.

I will look at this again later as I have to go out now.

I’m very curious to see what else is new in this version:

The simplest solution is to convert CityGML to a component and explode all groups in Gelände → CityGML. The model will then open correctly in SU Viewer for VR. I further simplified the file by exploding Klingewalder Höhe 2 (I had hoped that a top-level component would keep the other components and groups organized when opened in SU Viewer for VR. But no.).

I tried:

*Creating components out of all Groups in CityGML. This did not work.
*Creating components out of all Groups and SubGroups in CityGML. This did not work.
*Moving all SubComponents out of Components nested in the CityGML Component. This did not work.
*A bunch of other ways trying to preserve the overall structure of the file.

In general Einfügepunkt and Kontrollpunkt would render very far from Gelände → CityGML (as groups or components) in SU Viewer for VR. For whatever reason, nesting resulted in misplacement of Groups and Components relative to each other.

I’m speculating that a main reason for this problem is that Einfügepunkt is on the Z axis location of the Main Model View. The nested groups in Gelände → CityGML → Group → Group (of all SubGroups inside of Groups) are placed relative to the Model View/Einfügepunkt Z axis. But the Z axis of Gelände → CityGML → Group (the Groups in which the SubGroups align to the Z axis of the Main Model/Einfügepunkt) are on the Z axis of Gelände → CityGML.

Verrueckt machen!

Anyway, I haven’t been able to do a good job of explaining what looks like the problem. If you wanted to keep your Groups and SubGroups it seems those would have to have their axes moved.

I guess if the purpose is to only visualize and do a walkthrough in VR of a specific part of the model, you could always select the desired component, Save As a different skp and load that skp in VR.

Aris, are you able to use the file? It works well for me. It just doesn’t respect the ‘structure’ of the nested groups.

To be honest I got rid of everything else except for the terrain and the buildings which I dropped on the terrain and purged everything else (assuming that this is a visualization rather than a model organization exercise). But yes, that worked well.

Btw, if you folks want to stay up to date with the stuff we are working on we have opened an Alpha/Beta testing group for XR if you want to join. Read more here: SketchUp XR - Join our Alpha/Beta Testing Program

1 Like

Sorry, but I cannot see in the VR-App the updated model from James (Umgebung-neu-final.skp). Do you use another VR-Version?


I am using a recent version SketchUp Viewer for VR (2.5.31). There is a link to SketchUpViewerVR-2-0-0-5.exe from the link provided by Aris earlier in this thread.

I’m also opening SU Viewer for VR from the Oculus Home (see my previous link above about how to make sure that is working).

The model I uploaded, “Umgebung-neu-Final.skp”, should open above your head, like this:

Which devices are you using?