Sketchup Make 2017 - Installs but will not run


#1

Hello, have just attempted to install Sketchup Make 2017. Initial install said Visual C++ “14” Runtime Libraries (x64) would not install, and though SM 2017 installed would not open/run. Uninstalled everything, rebooted, and installed as Administrator… SM 2017 still would not open/run. Attempted repair on both C++ and SM 2017 … Still will not open/run.
Tried uninstalling / rebooting / etal again … still not working.

Does anyone have any suggestions.

Thank you for your time and help.


#2

When you installed it, did you right click on the installer and choose Run as administrator? Or did you just log in as the administrator?


#3

Hello, thank you for your reply.

First I just ran as admin. the second, third, and fourth times I right clicked and chose Run as Administrator.


#4

since you’ve tried installing it so many times, perhaps you should uninstall it and use a registry cleaner before trying to install it again.


#5

Thank you again for your suggestion. I just did this and everything appears to install smoothly without any difficulty, but when I attempt to open the program it begins but never opens ??? Any further suggestions?

Thanks again.


#6

So after cleaning the registry, you right clicked on the installer and chose Run as administrator?

Typically in the past, when SketchUp starts to open but quits, the problem has been related to the graphics drivers. Perhaps your GPU isn’t up to the task. You could check for driver updates.Try downloading and running SketchUp CheckUp What do you get? Install it using Run as administrator and follow the directions on the page.


#7

Thank you … I’ve downloaded SketchUp CheckUp, chose Run as Administrator, installed it, and attempted run it It ran through its processes and then, just as it seems to be finishing the scan and give results it quits and a message pops up that says “SketchUp CheckUp has stopped working A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.”

Also checked the graphics card and it’s drivers are current.

On this unit I run a bunch of Corel graphics programs, Adobe graphics programs, and various CAD programs with out difficulty. Also, SM 2015 runs great.

Must say, at this point I’m stumped. Was considering getting the Pro version but if the Make version won’t even run then I may need to pass.

Any further suggestions.

Really have appreciated your help. Thank you.


SketchUp Pro 2017 Windows 10 Not Responding
#8

I’m kind of running out of ideas. It could still be your graphics card which needs to support OpenGL 3.0 or higher. Hopefully one of the SketchUp team members will look in and offer a suggestion.


#9

In theory, the SketchUp installer is smart enough to ask Windows to install the Visual C++ Runtime Libraries. In certain situations Windows will fail to do this update properly, at which point SketchUp is pretty much out of options.

The folks who know the most about the windows installer are already gone for the day, but I’ll ask them to weigh in first thing on Monday morning. In the mean time, you may have some luck if you manually install the runtime libraries. Take a look at this thread for some more discussion:


#10

I’m checking into a new graphics card. Again, thanks for your time and help.


#11

Thank you. Have to head to some other events now, but will attempt to do so this weekend.


#12

I am having the exact same issue installing Sketchup Pro 2017. I have verified my GPU drive is up to date and manually installed Visual C++ “14” Runtime Libraries (x64). And yes, each time I attempted to install SU I right clicked on the installer and selected, “run as administrator”. For now I have re-installed Sketchup Pro 2016.


#13

Same here too.

I actually installed it (2017 pro) the other day. i opened the program just to check then closed it to finish some other work. When I tried to open it again it would just… stop. I uninstalled and re installed as administrator and now i get this

I have done a reinstall / repair but still gives the same pop-up.

When i run SU checker it also stops and says there is an error as other people have described here.


#14

Just saw this post, seems related to this issue: 2017 not launching
Definitely a video card issue and requires an updated driver to resolve.


#15

Thank you all for your input and help with finding a way to get SketchUp Make 2017 to run on my computer.

After checking and rechecking to find an update for my GPU driver and finding none, I opted to purchase a new Video Card. The Video Card is now installed and SketchUp Make 2017 is working fine.


#16

I am having a similar problem, but my SketchUp Make was working fine for a month on my new computer…I’m not replacing a new NVidia Quadro M4000 graphics card. Every other drawing program continues to work fine…the graphics card has the latest drivers as well.


#17

Does your SketchUp use the Nvidia card? Check the Nvidia control panel 3D application settings. Automatic selection uses the built-in Intel chip in your laptop.

Anssi


How do I force Sketchup application to use my NVIDIA Card
#18

Hello Anssi,

I assume that it is because the display in plugged into the nVidia port on the back of the computer. I had a minor problem with autoCAD when I first began using this new computer because the display was plugged into the Intel GP. …when I check the NVidia control panel in Device Manager I do not see a 3D option…

This is all strange because as I wrote, I’ve been using sketchup on this computer extensively for a month…last Friday I used it. Today it will not open, no matter how many times I uninstall and reinstall the program.


#19

Did you use Run as administrator when you installed it?

What exactly happens when you try to open SketchUp?


#20

I did not run as administrator…when I click on the desk top icon, or the icon pinned to my task bar, the SketchUp menu pops up, when I click Start Using SketchUp tab the menu disappears…then a report error menu pops up (BugSplat?) asking for my email, name and brief description of the problem.

I am stumped because I’ve been using this program on this computer extensively for a month. I used it last Friday, went away for the weekend, attempted to use it this morning and nothing…