Sketchup 2017 Installs and wont start. NEW HARDWARE

I have been unable to use sketchup 2017.
it installs fine. Once a template is chosen it bugsplats.
I have reinstalled C++ redistributables. Reinstalled Sketchup as administrator. Registry cleaned. updated video drivers.
rinse repeat. again. and again.
With NO success.
It works fine on at least three other machines. This computer is a Razer Blade Pro with a 1080… So… it should great.
No there is not an Intel management graphics chip on this computer. Just a 1080.

Did you install by right clicking on the installer and then Run as administrator or were you just logged in as the administrator?

Yes every time.

An ambiguous answer.

To clarify…
Did you install SketchUp by selecting its installer exe file, right-clicking > context-menu > "Run as administrator"
You being the admin is not the same, and running apps as admin [as opposed to having admin-powers] is not really recommended.

Also do not think to modify the SketchUp.exe to ‘Run as admin’, because that then prevents operations like drag-n-drop - Windows-Explorer always runs at the base level, and is then prevented from affecting any apps with elevated permissions…

If you are unsure about how you installed it, there’s no need to uninstall/reinstall…
Close SketchUp, then run the installer again - using “Run as administrator” - as explained - when prompted choose ‘Repair’…

Yes, what? Which one are you doing?

Crashes related to C++ stuff: see threads for solutions for that.

DID THAT. See original post.
Current Redist is “x64 14.0.23026” before install/repairs/etc/

The last attempt process…
uninstall sketchup 2016 Make and 2017 Make.
uninstall C++ 2015 redist 64
check for video driver update, nothing new needed
check for windows update, nothing new needed
registry cleaner
restart computer
install new download of c++ redist from microsoft version 14.0.23026
install SketchupMake-en-64.exe with right click “run as administrator”

BUGSPLAT

This most recent process is after much online research and many other failed attempts.
Part of me thinks it is an OpenGL error, as i have read/heard much about such in Pascals Nvidia tech.

Bug Splats at startup are commonly caused by OpenGL errors so you might be on the right track. GPU drivers would be the next place to check.

Are you sending in the Bug Splats with identifying info so that someone on the team can link those reports to you?

Yea, if you don’t have other programs using it, the sure way would be to uninstall ALL versions of Microsoft Visual C++ 2015 Redistributable. Then reinstall SketchUp… otherwise, I’ll let the Sages here who know more about it than me pitch in.

Today I started sending my contact information along with the splat.

Are you just recommending the C++ 2015 Redistributable or all C++ Redistributables?

I don’t have new hardware but I’m trying to install Sketchup to test it out, but all I get is the bug splat.
Uninstalled Sketchup 2017 64bit
Uninstalled C++ 2015 Redistributable
re-installed “As Administrator” and C++ re-installed.
Still getting the splat when I fire up SketchUp

I run Solidworks and AutoCAD so I really don’t see this being a GPU issue.

I didn’t see any advantage of uninstalling any additional redistributables…

It is a 1080 in the laptop. Thus no optimus gpu controller. I dont think any 10 series mobile graphics have the opimus controller.

I hear you. I dont see the HD graphics included in my machine. and i believe there are many new laptops that arent using Intel HD graphics at all.
https://www.intel.com/content/dam/www/public/us/en/documents/product-briefs/hm175-qm175-chipset-brief.pdf
In any manner, there is no option in the nvidia control panel for anything other than the discreet graphics.
I do a lot of VR work that drove to getting a machine that would not have Intel HD graphics as an option as that disabled use of VR headsets.

Only settings here are “uaw global setting” / Auto select / and GeForce GTX 1080

A global settings drop down selections are Auto Select / and Geforce GTX 1080

They have always been set to “geforce gtx 1080”

image

Hey jsteinert, is this crash still an issue for you?

Dzinengr - it should be sufficient to reinstall the C++ 2015 Redistributable. I just looked at the bugsplat reports, I don’t see any with your name on them so I can’t confirm whether or not you have the “bad” version of the mfc140u.dll.

-m

Thanks Marc. Mine should be named as scott hammac.

Yes. Still having issue on the Razer Pro 2016. I just submitted another bugsplat. joshua.steinert

if you read my post, i included information available in “global settings”. which have always been set to the discreet graphics card. I appreciate the assistance, but can we move past a nonissue?