SketchUp 2017 Started Crashing

win10
nvidia
quadro
windows10

#1

I have been using Sketchup Make 2017 since April 2017 (and other versions for many years). It is now crashing when I select “Start using Sketchup” and giving the BugSplat dialog. This is on Windows 10 64-bit on a Lenovo P70. It was working a week ago. I have read the related topics but not found a solution. I have done the following:

  1. Delete AppData/Roaming/Sketchup 2017 to be sure it is clean.
  2. Uninstall then Reinstall with latest download (several times).
  3. Check for Microsoft Visual C++ 2015 Redistributable in Add/Remove Programs (it is not there).
  4. Download Visual C++ 2015 Redistributable Update 3. (Fails to install because another version is already installed. Latest is Visual C++ 2017 Redistributable 14.10.25008. There is none with 2015 in the name.)

The graphics driver has not changed and is NVIDIA Quadro M4000M. The only significant change is a BIOS update since it was last working, but the BIOS settings have not changed. (I checked.) It is using the NVIDIA card, as checked in Device manager and the BIOS, and not Integrated Graphics. Other 3D programs work all right. Lenovo Update does not indicate there is a new NVIDIA driver. (It did indicate the BIOS and I did all recommended updates.)

I have submitted the BugSplat with my email address, but got no reply. I have looked at the logs, but do not see a cause for the crash. I am out of ideas, and it is leaving me dead in the water. Thanks for any help.


Cannot launch Sketchup Pro 2017, nothing happens
What’s up with SketchUp Make?
Cannot launch Sketchup Pro 2017, nothing happens
#2

You say you uninstalled and reinstalled several times. When you installed it, did you right click on the installer and choose Run as administrator? If not, you need to do that. Double clicking on the icon or clicking Run isn’t enough to get it installed correctly.


#3

I believe I did that the last time. (But I always get the UAC prompt anyway.) In any event, I uninstalled and reinstalled again just now, and it still doesn’t work.


#4

Check that SketchUp is set to use the Nvidia GPU in Nvidia Control Panel. (There are reports that Windows 10 Updates are resetting power saving features, that cause most applications to default to the integrated Intel GPUs.)


#5

I don’t find an option to use any particular GPU in the NVIDIA Control Panel. With the BIOS set to Discrete Graphics, the Intel card does not appear in device manager. Only The NVIDIA card. So there is only one video card, and apparently that why there is nothing to choose.

I have not made any changes to the NVIDIA Control Panel, and do not typically use it. In particular, it has not been changed since April 2017, when I installed SketchUp update 17.2.2555.0. (The original was installed in December 2016.) I have used SketchUp regularly during that time, and it worked fine until about a week ago.

I have installed the Creator’s Update manually, and it was working after that.


#7

@KennethEvans, I looked through the BugSplat database and I believe I’ve found your most recent BugSplat report (for SketchUp team members the crash ID is 225782).

The crash does not appear to be related to OpenGL or your NVIDIA graphics drivers. Instead it appears to be occurring inside Microsoft’s user interface framework (MFC). I know there were no graphics driver updates on your machine but can you see if the Visual C++ Redistributable was recently upgraded by a Windows or Lenovo update?


#8

I fortunately I have a pretty good time history.

5-4 Creator’s Update
5-20 SketchUp was working. (I have hand-dated printouts of my plans.)
5-21 Lenovo System update.
5-23 SketchUp was not working.

The only Windows update in the history for this time period was:
5-23 Windows Malicious Software Removal Tool for Windows 8, 8.1, 10 and Windows Server 2012, 2012 R2, 2016 x64 Edition - May 2017 (KB890830)

The latest Visual C++ Redistributable’s were on 5-4, presumably with the Creator’s Update.

  • So no indication of any changes that would affect MFC.

I know of no other changes to the system in this time period other than the Lenovo Update.

The Lenovo update history does not seem complete. For example, there is no mention of The BIOS update on 5-21 but it is in my notes. From the Lenovo history, I get:

  • Intel Management Engine 11.0 Firmware 7/8.1/10 [64] V11.6.25.1229

From Add/Remove programs, I get:

  • 5-21 Lenovo System Update
  • 5-22 Intel Management Engine Components
  • 5-22 Intel PROSet/Wireless Software

Debugging myself with Visual Studio, I tried attaching to SketchUp.exe before trying “Start using SketchUp”. After selecting that it crashed with:

‘SketchUp.exe’ (Win32): Loaded ‘C:\Windows\System32\WindowsCodecs.dll’. Cannot find or open the PDB file.

Exception thrown at 0x00007FF784D28EDD in SketchUp.exe: 0xC0000005: Access violation reading location 0xFFFFFFFFFFFFFFFF.

Without the code, I can’t get any more information, and perhaps you already know this.


What’s up with SketchUp Make?
What’s up with SketchUp Make?
#9

It’s still not working, I cannot use Sketchup at all.


#10

Honestly, I think Sketchup is forcing everyone to switch to SketchupFree 2018 or SketchupPro 2018 (as they are discontinuing the SketchupMake for any year before that). Aka, there will no longer be any free downloadable Sketchup programs…only the free web browser one (SketchupFree) or the paid version (SketchupPro). :frowning: I got SketchupMake 2017 crashing with a bug splat too.


#11

Did you ever try updating your graphics driver (either from Lenovo or directly from Nvidia)? I have seen many times that after a Windows or other system update things with SketchUp or other OpenGL-using software start to go weird, and installing a graphics driver update fixes things.


#12

Anssi,

Thanks for your response. At the time there were no new graphics drivers. However, there is now one released for the Fall Creators Update. I did just install it. It does not fix the problem.

To be sure, I uninstalled Sketchup Make 2017 and reinstalled it. First I deleted AppData\Roaming\Sketchup/Sketchup 2017 to be sure it was a clean install.

It still does not work. After pressing “Start using SketchUp”, there is a busy cursor for a few seconds, then nothing. I no longer get a Bug Splat dialog.

Since my last post, I have installed SketchUp Make 2016 using an installer I had archived. It works OK. Other OpenGL programs, such as Google Earth also work fine.

I have tried SketchUp Free and find it doesn’t allow extensions, doesn’t support the 3D mouse, and (from other reports) has slow performance. It is a real downgrade.

So I guess I’ll use SketchUp 2016 ongoing. For my needs it does not make sense to get the full version (which may have the same problem).

There is an active forum topic on “What’s up with SketchUp Make”, so there is no need to discuss Trimble’s dropping support for Make further here.


#13

But in your case, Win7 with AMD card, it’s a finding the right driver issue and making sure you are using the dedicated graphics card instead of the integrated graphics. SU17 upgraded to OpenGL 3.0 so that why it runs on your set-up now. Check that your laptop is using the AMD card. In SU, go to Window > Preferences > OpenGL > Graphics card details.


#14

@KennethEvans, you might try running the SketchUp 2017 Checkup utility. It creates a log file archive on the desktop with a “.sulog” extension. (It’s just a zip archive really with logs inside it.)

Other than that, is it possible to walk back the BIOS update, and see if SketchUp 2017 starts working again ?

The 2017 versions will not be updated any more so there is not likely to be a fix coming from any update.

[P.S. - If you computer properties have changed please update your profile settings.]


(And I’m also in the same boat, using 2016 version on a machine that will not run 2017+.)


#15

The problem has been solved. Sketchup 2017 is running again for me.

It turns out Photoshop was crashing after I updated the graphics driver recently. I traced that down to DLLs associated with 3Dconnexion (the 3D Mouse) and it was resolved by updating the 3Dconnexion drivers.

I checked to see if it had fixed Sketchup, and it hadn’t. However, for some reason I got a BugSplat dialog again (it apparently doesn’t happen for repeated errors of the same type) and I sent a report (why not?). The response I got this time was different from before (see the top of this post), and it had the correct solution.

The problem is with a Microsoft Foundation Class (MFC) DLL from Microsoft, C:\Windows\System32\mfc140u.dll. I updated to the latest version by downloading a new VC_redist.x64.exe from Microsoft. Running it updated mfc140u.dll from 14.0.24210.0 to 14.11.25325.0.

The detailed instructions are in the response to the BugSplat located here. Hopefully, it will remain, but if you are having this problem and your version is not the later one, installing the latest VC_redist.x64.exe from Microsoft might fix it.

Note that the solution is consistent with the response from thayer above. It is unfortunate there was disconnect in getting the information to fix it to me. If I hadn’t done things to get a new BugSplat, I might never have found out.


#16

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.