SketchUp Make 2017 Components / 3D Warehouse offline again?

Dear all,
i am using Sketchup Make 2017 with the component library. However since some weeks it seems to be not available. I had the same issue roughly 1 year ago.
It was solved in this thread: SketchUp Make 2017 Components / 3D Warehouse offline?

Now i do have the same issue again.
Can someone help to bring it online again?

Thank you alot!

The 3D Warehouse has not supported SketchUp 2017 for a number of years. If you want to get components from the Warehouse to use in SU2017, go to the 3D Warehouse in your internet browser, download the COllada file for the component you want. Extract the contents of the ZIP file and import the included .dae file into SketchUp.

That boat sailed long ago. Don’t expect it to come back to get you.


3D Warehouse for SU Make 2017 is dead and buried! See @DaveR’s response on how to get into bringing Collada files into Make.

Personally I find it a bit of a faff so rather than do that I build my own models which is really improving my modelling skills.


Hello, i know that the warehouse is deactivated in sketchup 2017 since some years. But till some weeks i was still able to load models via the components tray in sketchup 2017. But i am getting an error message now. Same error like in my old thread in the first post. Back than it was fixed by a sketchup team member. Maybe we do have the same issue again and it can be fixed again?

It won’t be back again - it’s well and truly gone now.

1 Like

Also using the component tray? Thats sad. I worked well till some weeks ago…

I tried this workaround. But i need a paid sketchup account for this, correct?

No. You need a trimble user account but that doesn’t cost anything.

I do have a trimble user account. But if i want to export my Sketchup-Web-Version Model to Collada i have to click “upgrade” and get forwarded to … am i am doing something wrong?

Well, that’s different. Upload your model to the 3D Warehouse and then find it in the Warehouse in your browser and download the Collada file.

Ahh … thank you for the hint!! Thats working well.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.